AWS Kinesis

I am following the AWS kinesis installation steps for the G - Streamer plugin, but during installation the Jetson Nano is giving me this error:

uda-drivers-450 : Depends: libnvidia-compute-450 (>= 450.51.06) but it is not going to be installed
Depends: libnvidia-gl-450 (>= 450.51.06) but it is not going to be installed
libnvidia-decode-450 : Depends: libnvidia-compute-450 (= 450.51.06-0ubuntu1) but it is not going to be installed
libnvidia-ifr1-450 : Depends: libnvidia-gl-450 but it is not going to be installed
nvidia-compute-utils-450 : Depends: libnvidia-compute-450 but it is not going to be installed
nvidia-driver-450 : Depends: libnvidia-gl-450 (= 450.51.06-0ubuntu1) but it is not going to be installed
Depends: libnvidia-compute-450 (= 450.51.06-0ubuntu1) but it is not going to be installed
nvidia-utils-450 : Depends: libnvidia-compute-450 but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution)

Hi,

You fix the unmet dependencies, run the suggested command

sudo apt --fix-broken install

Could you share the installation steps you’re following?

Best Regards
Angel

I am following the steps on this page:https://docs.aws.amazon.com/kinesisvideostreams/latest/dg/gs-send-data.html

After downloading the c++ producer library, I am told to run these following commands:

  • sudo apt-get update
  • $ sudo apt-get install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev gstreamer1.0-plugins-base-apps
  • $ sudo apt-get install gstreamer1.0-plugins-bad gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-tools

The error still persists even after running the broken install comand.

Seems there is something broken on your Jetson Nano related to NVIDIA drivers. Because GStreamer packages are not related with NVIDIA dependencies (Error log).

Commonly, the GStreamer packages are already included on Jetson Nano software.

Run this command to check

pkg-config --list-all | grep -i gst

Angel

Thanks for the reply, but even after running the command, I am confused as to what I need to fix in terms of the drivers itself:

sudo apt --fix-broken install

The error comes as below:
sudo apt --fix-broken install
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages were automatically installed and are no longer required:
apt-clone archdetect-deb bogl-bterm busybox-static cryptsetup-bin dpkg-repack
gir1.2-timezonemap-1.0 gir1.2-xkl-1.0 grub-common kde-window-manager kinit kio
kpackagetool5 kwayland-data kwin-common kwin-data kwin-x11 libdebian-installer4
libkdecorations2-5v5 libkdecorations2private5v5 libkf5activities5 libkf5attica5
libkf5completion-data libkf5completion5 libkf5declarative-data libkf5declarative5
libkf5doctools5 libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5
libkf5idletime5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5kcmutils-data libkf5kcmutils5
libkf5kiocore5 libkf5kiontlm5 libkf5kiowidgets5 libkf5newstuff-data libkf5newstuff5
libkf5newstuffcore5 libkf5package-data libkf5package5 libkf5plasma5 libkf5quickaddons5
libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5
libkf5textwidgets-data libkf5textwidgets5 libkf5waylandclient5 libkf5waylandserver5
libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libkscreenlocker5
libkwin4-effect-builtins1 libkwineffects11 libkwinglutils11 libkwinxrenderutils11
libqgsttools-p1 libqt5designer5 libqt5help5 libqt5multimedia5 libqt5multimedia5-plugins
libqt5multimediaquick-p5 libqt5multimediawidgets5 libqt5opengl5 libqt5positioning5
libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5quickwidgets5 libqt5sensors5 libqt5sql5
libqt5test5 libqt5webchannel5 libqt5webkit5 libxcb-composite0 libxcb-cursor0 libxcb-damage0
os-prober python3-dbus.mainloop.pyqt5 python3-icu python3-pam python3-pyqt5
python3-pyqt5.qtsvg python3-pyqt5.qtwebkit python3-sip
qml-module-org-kde-kquickcontrolsaddons qml-module-qtmultimedia qml-module-qtquick2 rdate
tasksel tasksel-data
Use ‘sudo apt autoremove’ to remove them.
The following additional packages will be installed:
libnvidia-compute-450 libnvidia-gl-450
The following NEW packages will be installed:
libnvidia-compute-450 libnvidia-gl-450
0 upgraded, 2 newly installed, 0 to remove and 327 not upgraded.
71 not fully installed or removed.
Need to get 0 B/64.3 MB of archives.
After this operation, 258 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
debconf: delaying package configuration, since apt-utils is not installed
(Reading database … 180562 files and directories currently installed.)
Preparing to unpack …/libnvidia-compute-450_450.51.06-0ubuntu1_arm64.deb …
Unpacking libnvidia-compute-450:arm64 (450.51.06-0ubuntu1) …
dpkg: error processing archive /var/cache/apt/archives/libnvidia-compute-450_450.51.06-0ubuntu1_arm64.deb (–unpack):
trying to overwrite ‘/usr/lib/aarch64-linux-gnu/libcuda.so’, which is also in package nvidia-l4t-cuda 32.4.2-20200408182156
Preparing to unpack …/libnvidia-gl-450_450.51.06-0ubuntu1_arm64.deb …
Unpacking libnvidia-gl-450:arm64 (450.51.06-0ubuntu1) …
dpkg: error processing archive /var/cache/apt/archives/libnvidia-gl-450_450.51.06-0ubuntu1_arm64.deb (–unpack):
trying to overwrite ‘/usr/share/glvnd/egl_vendor.d/10_nvidia.json’, which is also in package nvidia-l4t-3d-core 32.4.2-20200408182156
Errors were encountered while processing:
/var/cache/apt/archives/libnvidia-compute-450_450.51.06-0ubuntu1_arm64.deb
/var/cache/apt/archives/libnvidia-gl-450_450.51.06-0ubuntu1_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Hi,

Usually, nvidia-driver is for the desktop environment.
Jetson driver is integrated into the OS and cannot be separately installed.

Would you mind to share the page you follow so we can give a further suggestion?

Thanks.

Same problem. Any update?