Axis IP Camera stream to Jetson Nano

Good Afternoon all

Newbie here first time running Jetson.
What would be the correct way to stream Axis P3935LR?
The example for the RTSP below. Camera sits at 192.168.0.111 address

|Main stream|rtsp://:@:/axis-media/media.amp|
|Sub stream|rtsp://:@:/axis-media/media.amp?videocodec=h264&resolution=1280x720|

Sub stream configuration:

  • videocodec: h264 or h265
  • resolution: 1920x1080 or 1280x720

Default RTSP port: 554
Example: rtsp://viewer:pass@123.123.123.123:554/axis-media/media.amp

Thank you in advance.
Kris

please refer to Jetson Nano FAQ for examples of running RTSP streaming,

Hiya.
I followed the FAQ and ended up with this

kris@kris-desktop:~/Downloads$ Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://root:root@192.168.0.111:554/axis-media/media.amp?videocodec=h264
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
Progress: (request) SETUP stream 0
Progress: (request) SETUP stream 1
Progress: (open) Opened Stream
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Progress: (request) Sending PLAY request
Progress: (request) Sending PLAY request
Progress: (request) Sent PLAY request
ERROR: from element /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0/GstUDPSrc:udpsrc0: Internal data stream error.
Additional debug info:
gstbasesrc.c(3055): gst_base_src_loop (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0/GstUDPSrc:udpsrc0:
streaming stopped, reason not-linked (-1)
Execution ended after 0:00:00.145009758
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

type or paste code here

Any idea what to do next?
I`m sure that the URL is correct and the user and pass also. I use that to view the stream through browser.
thanks

hello k.chlapek,

did you execute test-launch to enable the stream? please share your step in details for reference, thanks

Hello

It does appear that my company is blocking something not allowing the remote desktop to forward the stream.
I managed to get the image directly on the Jetson, but the LAG is just unmanagable, it is like 2/3 seconds delay on the image displayed vs what camera see therefore this Gstreamer is probably a no go. I did see that others have problem with low latency RTSP but I have not found any low latency solution yet.
Thanks

hello k.chlapek,

may I confirm the device setup, for example, where you’ve this IP camera connected?
were Jetson Nano and this IP cam in the same domain?

Appologies for late reply.
The ip camera and jetson is connected through cat5 cable directly to POE switch. They sit on the same network.

Hi,
Please try this command and see if it works:

$ gst-launch-1.0 rtspsrc location="rtsp://viewer:pass@123.123.123.123:554/axis-media/media.amp" ! fakesink

To make sure the RTSP source is valid.

And we suggest use Jetpack 4.6.4 which is latest release for Jetson Nano.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.