Backlight control stopped working after upgrade to Linux 5.8

After upgrading to kernel version 5.8 on my Arch Linux machine, backlight controls stopped working for my GeForce GTX 775M Mac Edition. With kernel 5.7.12 and NVIDIA drivers 450.57, everything was working fine. Upgrading to kernel 5.8 and keeping drivers at version 450.57 broke the backlight controls.

I tried changing the backlight in GNOME (running on Xorg, not Wayland) and also by directly writing to /sys/class/backlight/acpi_video0/brightness. In both cases, the file content is changed successfully, but the backlight stays at full brightness.

I also tried setting the kernel parameter acpi_backlight to video, vendor, native and none, but none of this helped.

The problem still persists with kernel 5.8.9 and drivers 450.66.

I’d be happy to provide more details if needed.

nvidia-bug-report.log.gz (258.9 KB)

Update: I observed that the backlight controls start working when I resume from suspend to RAM. (I’m currently running NVIDIA drivers 455.23.04 and kernel 5.8.10.) Moreover, when I resume from suspend, the backlight will always be at 100 % even if it has been set to a lower level before suspend. But at least it then starts reacting to subsequent changes.

Any ideas how to investigate this further?