Backup device image error for xavier nx/jp5.1.2

Hi nv team,

I want to backup image for the product with xavier nx.
I have done this work for jp5.0.2 image previously.
following the same steps, I can’t backup jp5.1.2 image correctly.

here is the error:
(when device is rcm mode, the backup cmd:
sudo ./tools/backup_restore/l4t_backup_restore.sh -b -c jetson-xavier-nx-devkit-emmc)

/home/samwise/nvidia/nvidia_sdk/JetPack_5.1.2_Linux_JETSON_XAVIER_NX_TARGETS/Linux_for_Tegra
***************************************
*                                     *
*  Step 3: Start the flashing process *
*                                     *
***************************************
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for device to expose ssh ......RTNETLINK answers: File exists
RTNETLINK answers: File exists
Device has booted into initrd. You can ssh to the target by the command:
$ ssh root@fe80::1%usb0
Cleaning up...
Log is saved to Linux_for_Tegra/initrdlog/flash_3-1.4_0_20240403-194319.log 
Run command: 
ln -s /proc/self/fd /dev/fd && mount -o nolock [fc00:1:1::1]:/home/samwise/nvidia/nvidia_sdk/JetPack_5.1.2_Linux_JETSON_XAVIER_NX_TARGETS/Linux_for_Tegra/tools/backup_restore /mnt && /mnt/nvbackup_partitions.sh -e mmcblk0p1 -n  && echo Backup image is stored in /home/samwise/nvidia/nvidia_sdk/JetPack_5.1.2_Linux_JETSON_XAVIER_NX_TARGETS/Linux_for_Tegra/tools/backup_restore/images
 on root@fc00:1:1::2
**cat: /sys/block/mmcblk0p1/size: No such file or directory**

and the attach file is one full initrdlog.

Is there any possible reason, how to fix it?
thank you.
flash_3-1.4_0_20240403-194319.log (9.2 KB)

mmcblk0, not mmcblk0p1.

There is a bug in l4t_backup_restore.sh

device_to_backup=mmcblk0p1

should be
device_to_backup=mmcblk0

Alternaltively, you could use
sudo ./tools/backup_restore/l4t_backup_restore.sh -e mmcblk0 -b -c jetson-xavier-nx-devkit-emmc)

1 Like

this is the right answer.
thands to your detailed reply.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.