banding/dithering on optimus laptop

i’ve noticed an issue with banding on gradients and in other situations i would be able to enable dithering which seems to help however myself and others using intel/nvidia optimus laptops dont have such an option available in nvidia-settings and i’ve tried manually modifying .nvidia-settings-rc to force it without success. i’ve tried many different xorg configurations as well but still banding remains.

i spend a good deal of time helping others with nvidia related issues but i’m not able to solve this one and would greatly appreciate some suggestions. i’ve included some relevant system/nvidia info below, if more is needed i will gladly provide it.

inxi -v7z
https://pastebin.com/1sDzCZeH

nvidia-smi -a
https://pastebin.com/6rc92bjZ

the current prime setup im using is a collection of scripts i created for switching between prime (intel/nvidia) and intel only modes with the nvidia disabled but this issue im referring to is in regard to only the nvidia prime setup.

thanks in advance.

nvidia-bug-report.log.gz (1.16 MB)

Since the display is driven by the intel gpu, the i915 driver is responsible for dithering, the nvidia driver doesn’t have influence on it.
The i915 kernel driver should automatically enable dithering on 6bpp panels but this was subject to breakage before. Did you try with another kernel version?

yes, seems to be consistent across kernels and to be sure i just tried 4.14, 4.19, 5.1, and 5.2 . i’ll have to give another look at the i915 driver and try some various parameters and see if it improves anything. if i manage to come up with anything i’ll post it here since it seems that this is a fairly common issue and there’s not much out there in regards to optimus laptops and dithering/banding. any suggestions would be certainly appreciated. thank you for the response and clarifying which gpu i should focusing on.