bandwithTest failed

Hi, all:

I had a fresh installation* of cudatookit 2.2 and cudasdk 2-2.21 on a MacBook Pro with Mac OS X 10.5.8. Everything went ok until I run bandwidthTest, which gives an error
“udaSafeCall() Runtime API error in file <bandwidthTest.cu>, line 667 : no CUDA-capable device is available.”

I have /usr/local/cuda/bin added into path, and /usr/local/cuda/lib added into DYLD_LIBRARY_PATH .

I post below the output of deviceQuery and bandwidthTest :

=============================
[dh11:bin/darwin/release] % ./deviceQuery
CUDA Device Query (Runtime API) version (CUDART static linking)
There is no device supporting CUDA.

Device 0: “Device Emulation (CPU)”
CUDA Capability Major revision number: 9999
CUDA Capability Minor revision number: 9999
Total amount of global memory: 4294967295 bytes
Number of multiprocessors: 16
Number of cores: 128
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 16384 bytes
Total number of registers available per block: 8192
Warp size: 1
Maximum number of threads per block: 512
Maximum sizes of each dimension of a block: 512 x 512 x 64
Maximum sizes of each dimension of a grid: 65535 x 65535 x 1
Maximum memory pitch: 262144 bytes
Texture alignment: 256 bytes
Clock rate: 1.35 GHz
Concurrent copy and execution: No
Run time limit on kernels: No
Integrated: Yes
Support host page-locked memory mapping: Yes
Compute mode: Default (multiple host threads can use this device simultaneously)

Test PASSED

Press ENTER to exit…

=============================

[dh11:bin/darwin/release] % ./bandwidthTest
Running on…
device 0:Device Emulation (CPU)
Quick Mode
Host to Device Bandwidth for Pageable memory
cudaSafeCall() Runtime API error in file <bandwidthTest.cu>, line 667 : no CUDA-capable device is available.

========================

Could anybody give an advice please?

Thanks

*Actually I first installed cudatookit and cuda sdk 2.3 then later uninstalled it by deleting /usr/local/cuda. I then installed cudatookit and sdk 2.2. The error message I got are the same in both installations.

A reply to myself. I tried the following and it worked.

  1. delete

/usr/local/cuda

/System/Library/Extensions/CUDA.kext

/System/Library/StartUpItems/CUDA

  1. Install the toolkit and sdk. When installing tookit, go to custom install and check all three boxes.

Thanks.

Please be sure that you have writes to interact with graphics card. give rights to your user to read and write to Graphics Card.

Good Luck :teehee:

I dont think ist an rights problem.

look at the first post. The problem is that the user wants to run the cuda bandwithtest on CPU device and NOT GPU.
Perhaps that cant run and also doesnt make any sense.