Basler USB Camera not working

I have a basler ace aca1920-40uc camera and am trying to connect it to a jetson nano. Pylon view (basler’s software) can see the camera, but when it tries to actually connect to it i get the following error:
Failed to open device ‘2676:ba02:1:2:8’ for XML file download. Error: ‘The device cannot be operated on an USB 2.0 port. The device requires an USB 3.0 compatible port.’

I igured it might be something to do with power, but using an external hub with separate power hasn’t fixed it, and changing from micro usb to barrel jack power hasn’t changed anything. I’m completely lost so any help would be great

Hi,
Is the camera enumerated as highspeed device(USB2) or superspeed device(USB3)? Can it be run in v4l2-ctl command?

Embarrassingly it turned out to be due to the low quality cable i was using

Did you managed to work Basler Camera? I have a camera which is Basler Ace 4024 29um usb 3.0. I have doubt whether I operate that camera with pypylon.

We were able to use the Basler acA3088-57uc camera with Nano. D3 had a little demo of this camera on Nano performing OCR. I’m not sure about the camera from the original poster but this camera did not use v4l2 and instead used the USB 3 Vision api. Basler has supporting software, including arm64 builds, that ran OK on Nano.

Regards,
Greg

I’m new to Nano or any developer platform. I successfully flashed the Nano software and used a Logitech webcam to capture both still and live images (using barrel jack power). I now want to use an acA2040-55uc USB 3.0 Basler camera and was wondering which Pylon software to download? Windows, Linux x86, Linux ARM to use with the Nano?
As well, I assume I will download the software to the microSD card on the Nano, reboot and use with the already flashed microSD card?
I don’t want to mess anything up.

You need the Linux ARM Pylon software. The Nano is an arm64 based machine.

Yes, you can download the software to the microSD card. You might not even need to reboot after installing. You’ll end up downloading a .deb file that you can install with:

sudo apt install ./NAME_OF_DEB_FILE

You might be able to install with a point-and-click interface but I’m not terribly familiar with installing that way.

Hello Greg,

Thank you very much for answering my question. I successfully downloaded, extracted the .deb file and tried point-and-click install. It does have a “Software Install” option, which I used, but nothing runs. I tried “Open With” and selected “Run Software”, but again nothing happens.
Via Basler they recommend opening Debian software via

sudo dpkg –i ./pylon*.deb

Basler recommends not using Ubuntu due to variations and possible errors. This is all ok, however, I’m completely ignorant regarding where I type ANY of these commands in. I’ve searched and do not understand how or where to type install or run commands. Where do I do this?

Ok, found out how to type in commands. I tried both commands (D3 of sudo apt install… and sudo dpkg-i….). When trying the dpkg, states cannot access archive, no such file or directory. When trying the apt install states it’s and unsupported file.

Any suggestions?

Change to the directory where the .deb package is. It’s probably in ~/Downloads.

cd ~/Downloads
sudo apt install ./pylon*.deb