Bayer camera not image output

HI nvidia:
I have a bayer camera sensor
dynamic_pixel_bit_depth = “10”;
csi_pixel_bit_depth = “10”;
mode_type = “bayer”;
pixel_phase = “grbg”;

pegasus@pegasus-ubuntu-2:~$ nvargus_nvraw --lps
nvargus_nvraw version 1.14.0
Number of supported sensor entries 6
Entry Source Mode Uniquename Resolution FR BitDepth Mode
Index Index Index CSI Dyn Type
0 0 0 zedxar0234_centerleft_0 1920x1200 59 10 10 Bayer
1 0 1 zedxar0234_centerleft_0 960x 600 120 10 10 Bayer
2 0 2 zedxar0234_centerleft_0 1920x1080 59 10 10 Bayer
3 1 0 zedxar0234_centerright_0 1920x1200 59 10 10 Bayer
4 1 1 zedxar0234_centerright_0 960x 600 120 10 10 Bayer
5 1 2 zedxar0234_centerright_0 1920x1080 59 10 10 Bayer

the driver can work on R35.3.1, but can not work on R35.4.1

can you give me some tips?
here is R35.4.1 log
my-dmesg-20240422.txt (96.2 KB)
my-trace-20240422.txt (6.6 MB)
nvargus-daemon-log-20240422.txt (43.2 KB)

hello helianyi,

according to kernel logs, it looks you’re able to enable camera sensor to have some exposure/frame-rate operations.
there’re some erroneous in your Argus daemon logs, some of them reported by incorrect tuning settings.
did you have ISP override files applied?
if yes, please give it a try to remove ISP files and also cache file under… /var/nvidia/nvcam/settings/ for testing.

BTW,
according to Release Notes (35.4.1).

To avoid a probe failure, the min_gain_val param sensors in DT should be set to greater than 1 in linear scale.

please also review your min_gain_val device tree property settings.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.