Benchmarking on P100 without BOOST

I have a P100 GPU and I want to run some benchmarks on it. If I run the same function 100 times, it takes a different amount of time per trial. I understand that this difference is due to CUDA Boost changing the clock frequency. I tried to disable the boost using nvidia-smi using the commnad

nvidia-smi --auto-boost-default=0

with persistence mode enabled, but it just says that changing boost is not supported for GPU. This procedure works for Maxwell/Kepler family GPUs but does not work on the P100

How can I disable boost on the GPU to get consistent measurements ?


the main function of boost is to adjust GPU clocks.

try setting the application clocks using nvidia-smi

I am also getting this error while trying to disable auto-boost on P100. I thought this was supported on all Tesla Cards? Or does it require a some special driver support. I am using CUDA 9 drivers.

It is not supported on all Tesla Cards.

If you want consistent clocks, you can use the application clocks or the clock range limits, that are possible with nvidia-smi.


nvidia-smi --help

and start reading.

If you set a particular application clock, that clock will be used with your application, without any adjustment, unless the GPU hits either thermal or power limits. You cannot enforce a particular clock if your GPU is throttling due to thermal or power limits.