Bin files missing from Sample Driveworks-2.2 in Xavier - B

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
NVIDIA DRIVE™ Software 10.0 (Linux)

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04


We have been trying to run the samples from driveworks-2.2 on AGX -Pegasus Xavier- B , But we noticed the Bin files missing in the driveworks-2.2.
The Driveworks-2.2 for Xavier A works Fine. not sure if the issues is related to flashing or it needs to be cross complied in the host PC first then transfered to make it work?

Dear @vimal.prasath ,
It is expected as Driveworks bin samples are shipped on only Xavier A, please check release notes(

Do we need to cross compile it on Xavier-B?
How to install deep learning libraries on Xavier (libraries such as PyTorch, Opencv-Python, Tensorflow)? I tried installing using pip but it haven’t worked.

Thanks and regards.

Dear @vimal.prasath,
Yes. you need to cross compile the sample. We do not officially support PyTorch/TF/OpenCV on DRIVE AGX platform. You may check native installation from source.
We recommend using TensorRT for optimal performance.

I am getting this error on Xavier-B

ImportError: cannot open shared object file: No such file or directory.

Dear @vimal.prasath ,
Could you please a seperate topic for new issues to avoid cluttering of topics.


1 Like