Bizarre black dots in top left corner of screen (ubuntu 12.04, gtx 570)

I have rectangular black dots in the top left corner of my screen. They blink on and off periodically, and sometimes they turn white. However, they never go away for more than around 3 seconds. Here’s a screenshot where you can distinctly see the scattered rectangular marks in the top left corner of the screen.

http://i.imgur.com/9PeIQJN.jpg

I am running Ubuntu 12.10. I’m using the driver provided by the nvidia installer, not the driver provided by my distribution.

  • Intel Core i5-2500k
  • EVGA GeForce GTX 570 HD (012-P3-1571-KR)

Steps to reproduce:

  • Start computer

nvidia-bug-report.log.gz:
https://dl.dropbox.com/u/1008737/nvidia-bug-report.log.gz

Hi,

I already wrote about the same problem ( https://devtalk.nvidia.com/default/topic/527808/linux/black-dots-in-top-left-screen-corner/ ) but didn’t get any comments from nvidia engineers.

Try changing cable , interchange gpu ports . Any earlier/previous driver resolves this issue?

2 ResidentMale:

Try to disable boot splash (http://askubuntu.com/questions/129738/can-i-disable-the-ubuntu-splashscreen) or switch to text console and back to desktop (ctrl-alt-f1 and ctrl-alt-f7). But it is bad solution! Users realy need bootsplash. I hope this will be fixed in nvidia drivers, it is bad when simple splash program cause such problems.

2 Sandip:

I don’t think that it is hardware or connection problem, you can find more details in my post (see link above).

Thanks a lot for sharing, Vandalf. You pinpointed where the problem relied accurately. I use uvesafb now in grub and this fixed it, following the instructions in http://idyllictux.wordpress.com/2010/04/26/lucidubuntu-10-04-high-resolution-plymouth-virtual-terminal-for-atinvidia-cards-with-proprietaryrestricted-driver/#comment-813

Thanks again.

Thank you for the hint but in my case using of uvesafb doesn’t help. I still think that it is nvidia drivers bug.

Hi Vandalf,
I’m not sure this is a problem of nvidia drivers. After the latest package updating (Ubuntu 12.04), my computer has gotten the same problem. I’ve spent a lot of time trying to find out the cause, without success. However, I’ve observed that after login, if I close the open session and login again, the problem disappears.
Why?, if the nvidia drivers are the same. Could you test this behaviour in your computer?

Chao!
rosebird.

Hi rosebird,

I have the same behavior, but I still think that it is driver problem. I think that well known black dots is the result of video memory contents or previous video mode switching of bootsplash (plymouth). This is not fatal system fault, so the driver must properly handle such problems. When I switch video card to Intel GPU on my notebook this problem disappears, so is is likely software driver problem.

Hi Vandalf,

Yesterday I solved the problem ;-D.
Firstly I tried downgrading the nvidia drivers to the previous version (295.40) because my computer had been perfectly working until last week, with this version. It didn’t work: the problem continued there.
Secondly, I decided to upgrade to the latest nvidia drivers (304.88) again: no success.
At the end, I executed “Repair broken packages” in “Recovery mode”. After it, I restarted my computer and “voilà”: the problem disappeared.

Now, my computer works fine again!

Chao!

Hi rosebird,

Are you sure that after recovery you have nvidia driver and not open source nouveau driver? And do you have now graphical boot splash (plymouth) enabled?

Perhaps, this is a KDE 4.10.x issue.
I’m experiencing the same behavior after switching to KDE 4.10.x, but it happens in rare circumstances.

Hi Vandalf,
I’m totally sure, my computer is working with nvidia driver and plymouth is enabled.
Have you tried the recovery process?

Hi,

xralph, this is not KDE issue, I have the same behaviour in GNOME environment.

rosebird, I use Debian linux distribution (not Ubuntu) and there is no such “recovery process”.

Hi, All. Glad to know I’m not all alone.

I am having the same issue. More than a bit annoying. The little black (and two white) specks pop up in the upper left quadrant of my screen upon booting up and every time a new program or browser window is opened, pretty much any time I click the mouse. Sometimes they go away if I don’t click for a while but often they don’t. These little buggers are THE blemish of my system.

I am running Ubuntu 12.04 LTS on an Asus G55VW with an Intel Core i7-3610QM CPU and NVIDIA GeForce GTX 660M 2GB GDDR5.

Here’s what it looks like on two different backgrounds:
http://www.bluemelon.com/farkle/untitled

The problem may have started after I used Super Boot Manager to change the plymouth. Since, I have uninstalled SBM, updated everything. Still got the ever-present speckled egg, though. Please help!

I am having the same problem with Ubuntu 12.04. I found a thread on the Ask Ubuntu form that discusses it and suggests the problem is related to mouse pointer movement and indicates the problem can be eliminated in Ubuntu 13.04, 64-bit, by installing an Intel driver.

Update: I downloaded the Intel driver and tried to install the package but I get an error message:
Dependency is not satisfiable: libglib2.0-0 (>=2.35.9)

Unfortunately the solution will not be as simple as downloading the file and double-clicking on it. :(

I encourage Nvidia to pay attention to black dots problem!

Hi all, Please provide nvidia bug report. Make sure below things are set on your system :

disable nouveau module is loaded.

  • create file :
    /etc/modprobe.d/nvidia-installer-disable-nouveau.conf

generated by nvidia-installer

blacklist nouveau
options nouveau modeset=0

  • add kernel parameter and reboot system: vga=0 rdblacklist=nouveau nouveau.modeset=0 video=vesa:off
  • reboot

Hi, sandipt!

I unable get graphical boot splash (Plymouth) using recommended kernel parameters. And of course there is no black dots artifacts in such case. But it is bad solution because many people need smooth boot process with graphical splash screen, especially for linux distributions targeted for industrial devices such as kiosks, cash desks, etc. Black boot screen with text kernel messages looks terrible and unprofessional.