Bizarre high usage of GPU

I just opened an empty sence in issac sim and the gpu fan started to scream.
The GPU is under high load in both realtime and interactive render modes. The GPU power reached up to 300W in the real-time mode. It’s crazy…

Interactive:

Realtime:


@sparrow_seaky supposedly it’s a normal behavior for OV. FWIW, here is mod’s response and explanation of the resource allocation:

Thanks for your support and your detailed explanation. I truly appreciate it. @Simplychenable

The running strategy of Omniverse is not very environmentally friendly and energy saving.
Looking forward to optimization.

1 Like

Having said this there are some additional details.

Under REALTIME you can set ECO MODE which is ON by default in USD Composer, but off by default in Issac Sim. I have asked for it to be on as well. However they say that Eco Mode can affect SDG.

With Eco mode on the GPU usage will drop dramatically from 100% to around 20% after it reaches that number of interations. Default in 100. Lower numbers resolve faster. Higher numbers give slightly better quality. You could set this as low as 10.

Under PATHTRACING you have the number of interations the same way but rather than in Eco Mode, it is just under normal render settings. Again it will use 100% of the card at max and then it will drop down to around 20% once completed.

By the way, that last 20% is mostly the realtime denoiser that is applied to both modes. If you turn that off, it will drop a lot more.

Finally there is a “pause rendering on minimize” in the rendering settings which does exactly what it sounds like.

Sorry, I don’t find the “pause rendering on minimize” in the rendering setting of issac sim. Could you show me a screen shot? Thanks!

i believe that’s a setting you should be able to find under Preferences.

this setting used to be under the Rendering section but since kit 105 and 2023 versions of Issac Sim, it’s now under the Developer. if you don’t see this setting, you can follow the post below to activate it. alternatively, you can tweak the arguments in the .kit file that’s shown in that post to set it as default values:

in your case, this is probably what you are looking for:

[settings.app.renderer]
skipWhileMinimized = true
1 Like

Thanks a lot! I’ve found the the “Skip Rendering While Minimized” following your guidance.
And I just found the “eco mode” in the render setting of Real-Time mode. After turning on it, the gpu usage seems normal.

1 Like

Great, I am glad you have found those two important settings. They will help keep your GPU a lot cooler !!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.