Black dots in top left screen corner

From time to time (not always, but on different hardware so it isn’t broken card) I get black dots on the top left corner of the screen.
Screenshot tool grabs this dots. I searched the web for solutions (it is known problem) and found only one working: switch to text (tty1) console and back (tty8 in my case). Artifacts exist on all driver and kernel versions. Is it possible to fix this problem by changing system or driver settings or it is driver bug? Maybe there’s some workaround, more convenient than tty switch? Please, help!

nvidia-dots.jpg

This bug exists for a long time on other than Debian distributions and desktop environments:

http://forums.linuxmint.com/viewtopic.php?f=49&t=114729&p=658225
http://worldforum.pardus-linux.nl/index.php?topic=3589.0
https://bugs.mageia.org/show_bug.cgi?id=6103#c34
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/421048

I tried 313.18 driver without success.

I found the reason of the artifacts: it is plymouth graphical bootsplash. Artifacts are visible when plymouthd doesn’t clear video memory after exit. Plymouth store video memory contents if for quit init.d plymouth script uses --retain-splash option. I removed this option, but bug still exist. In my situation plymouthd was in hang or crash state when init.d script send quit command before X start so it can’t do deinitialize sequence and it cause problems with nvidia driver. I don’t understand why such plymouthd behavior cause only nvidia driver problems? For example, Intel video driver works fine. Is it possible to cleanup system after plymouth abnormal exit to prepare system for proper nvidia start? Workaround with restarting plymouthd and then force it quit normally doesn’t help. It seems that something like video memory clean or video mode reset required but how to make it from the bash script?

P. S. My system is based on Debian Wheezy (i386), DE is GNOME 3.4.2 (GNOME classic mode)

Is this issue still reproduce if add kernel parameters :

vga=0 text rdblacklist=nouveau nouveau.modeset=0 video=vesafb:off

I unable get graphical plymouth boot screen using this parameters. So the bug is not reproducible in this case. But I really need graphical boot screen. This is customer requirement for linux distribution on which I’m working now.