Black screen after graphical login prompt


I am running Debian GNU/Linux 11 and I have a GeForce GTX 1060 3GB. I am using driver version 460.91.03-1.

When I leave my computer for a while, the screensaver kicks in. I am presented with a graphical login prompt,
I provide the credentials and then the screen turns black. This black screen lasts longer the more time I’ve spent away
from the computer. Sometimes I have to wait up to 5 minutes for the computer to respond. The mouse pointer is
very sluggish while this is going on. Any idea what I can do?

I have attached the bug report.
nvidia-bug-report.log.gz (820.4 KB)

Please check if this is triggered by the xfwm compositor by disabling it for testing.

I disabled the compositor and still managed to reproduce the problem. The screen wasn’t black this time though, but everything was still so sluggish that it takes maybe 30 seconds to move the mouse pointer across the screen.

Edit: Yeah, the screen is no longer black, but it still takes just as long before to make the system respond. Maybe I should try to run something like “top” in batch mode, sorted by memory consumption and see if anything is leaking memory?

After being left on during the night, it took 26 minutes after logging in before it “unfroze”. By unfroze I mean it stopped extremely sluggish. I can move the mouse pointer at snail speed, but all the windows’ contents are empty etc.

I ran a sorted list of applications running, sorted by memory usage, during the night.

while sleep 60; do top -b -o +%MEM | head -n 20 >> memory.log; done

Nothing very interesting there, other than the fact that after I logged in, the Xorg-process started
using 100% CPU for about 26 minutes.

If I turn on my computer in the morning, but leave it at the login prompt all day, I can then proceed to log in without any issues. It’s only once I’ve logged in and then idled out that the problem occurs. So I am guessing that something is initialized as part of the initial login process (maybe starting up xorg or my window manager) that ends up causing problems.

I did an strace on the xorg-process as it went into sleep (screensaver) and then after authentication/unlocking, but it’s not clear how I can pinpoint how it deviates from normal behavior.

There seems to be no solution in sight, so I have convinced a friend to trade me his inferior (hardware-wise) Radeon graphics card.

I found some others saying it’s a problem with the combination of having an nvidia-driver and the lightdm session manager in xfce4. Apparently if you can install xfce4-screensaver (found on Ubuntu, but not Debian) or xscreensaver as a replacement, that solves the problem. I will try this and confirm here if it works.

So the culprit was the light-locker (screensaver) in lightdm (session manager) in combination with the nvidia-driver package. Installing xscreensaver automatically replaced the built in screensaver, and solved the problem.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.