Black screen after install of nvidia driver ubuntu

made an account to paste what I had to get this trashfire working on a new thinkpad. why is this so much suffering

  • thinkpad extreme g3 32g ram
  • nvidia 1650 ti

bios settings that worked:

  • graphics mode: discrete
  • secure boot off
  • slow boot

os settings:

  • ubuntu 21.04 (18, 20 didnt work)
  • kernel 5.11.0-31 generic (5.10 might be easier to get working but I didn’t have any packages for it, avoid oem kernels)
  • driver: nvidia-driver-450 (and related deps)
  • nvidia-prime: yes
  • blacklist nouveau: yes

grub

GRUB_CMDLINE_LINUX_DEFAULT=“text”
GRUB_TERMINAL=console

Tried so many installs of the nvidia driver manually and so many versions/kernels, they all resulted in some form of a black screen/freeze. after may kernel swaps, reinstalls I tried an older ubuntu driver meta-package (nvidia-driver-450) and for some reason I haven’t had any black screens. I’m probably 1 apt-get install from calamity.

anyways, good luck friends

(to anyone reading from ubuntu or nvidia, I will pay you so much money for stable, easy to scaffold linux installs for portable desktop computing. why is this still so hard in 2021? )

1 Like

EDIT: I have managed to install video drivers for both Intel and Nvidia on MX Linux 19.4 KDE Plasma, AHS version.

I have prepared fresh Linux Mint 20.2 install on HP Pavilion 15-eg0079nw equipped with both: Intel i915 and Nvidia GeForce MX450 GPUs, 11th generation processor.

After installing updates, I installed nvidia v 460.91.03 driver from distro repositories. After rebooting I received black screen, but managed to ssh and created log in attachment. More info on Mint Forum

Can you help resolve the issue?

Guys can you help me with this ?

Greetings,

I am have long been struggling to get rid of the black screen.
Ubuntu 20.04, Nvidia-driver-470
GM107GLM [Quadro M2000M]

Have tried all solutions above many times but have not succeeded in months. With blackscreen I can still login via terminal and see all specs with nvidia-smi…

To start the gui I load older kernels like those in the 5.4.0-5XX-generic family to activate the gui. But at that stage I get the

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Attached is my log report.

Please let me know if you can suggest any fix.
Thank you

nvidia-bug-report.log (124.8 KB)

@generix I have a fresh ubuntu installation with this very same problem as posted here:

Considering that this is a fresh installation I don’t have the older kernel. Is it possible to downgrade the kernel in this situation?

1 Like

I’m seeing the same issues, but also Screen Flickering which I did not see above – so I created a new top-level post here: Black Screen and Screen Flickering in Ubuntu 20.04 with 470 drivers

I just upgraded my OS from ubuntu 20.04 to 21.04, and I found that my sceen stuck at

/dea/sda3:clean XXXX/XXXX files, XXXX/XXXX blocks

I have tried all methods mentioned above, incuding use ,run file and rep to install the driver. After a loooooooooong time trial and error, I fixed the problem by modifying my Xwrapper.config

Here are the details:

When I run sudo apt purge nvidia* to remove the installed driver, the system can work smoothly. As long as I put the driver in, the system stuck, but can use Ctrl + Alt + F2 to use tty.

And I happend to run startx, the error turned out


I just removed the line need_root_rights: yes, then startx and the desktop showed up.

My driver version:

Driver Version: 470.63.01

My kenerl version:

5.11.0-37-generic

Hope this can help someone.

1 Like

Dear all,

I write here after reading and trying all the related threads I could find about this.
I have an HPE server Proliant DL380 Gen10 with integrated graphics card (MATROX MGA G200eH3), with Ubuntu 20.04, and an nvidia Quadro RTX4000 (we’ve tested an RTX6000 as well).
Installed nvidia 470 drivers, no issues detected during installation

Problems encounteres so far:

  • xrandr command doesn’t ever show the displayport outputs of the nvidia card, only can see the integrated VGA output.
  • when using nvidia-smi, the GPU load is always at 0%. we tried with software which we know in other servers is succesfully using the GPU, but in this server it all goes to CPU.
  • we had several black screen problems, but we were able to sort it out by deleting the file /etc/X11/xorg.conf (fix that we saw in other thread). Before this, we had to purge the drivers for the server to restart.
  • All nomodeset parameters found in different files were deleted.
  • Server is NOT in secure boot mode.
  • No stray blacklist files were found ( /lib/modprobe.d/blacklist-nvidia.conf etc/modprobe.d/blacklist-nvidia.conf)
  • rest of the commands seem to show a “no problem” view: ‘lshw -c video’ shows both cards, nvidia-settings seem to work fine, prime-select query always shows ‘nvidia’, lspci show the nvidia modules…

I attach some of the outputs here:

innovation@innovation-holographics:/usr/sbin$ sudo lshw -c video

*-display
description: VGA compatible controller
product: MGA G200eH3
vendor: Matrox Electronics Systems Ltd.
physical id: 0.1
bus info: pci@0000:01:00.1
version: 02
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=mgag200 latency=0
resources: irq:17 memory:d8000000-d8ffffff memory:d9b98000-d9b9bfff memory:d9000000-d97fffff memory:c0000-dffff
*-display
description: VGA compatible controller
product: TU104GL [Quadro RTX 4000]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:86:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: iomemory:d7f0-d7ef iomemory:d7f0-d7ef irq:433 memory:f0000000-f0ffffff memory:d7fe0000000-d7fefffffff memory:d7ff0000000-d7ff1ffffff ioport:a000(size=128) memory:f1080000-f10fffff

innovation@innovation-holographics:/usr/sbin$ lspci -k |grep nvidia
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
Kernel driver in use: nvidia-gpu
Kernel modules: i2c_nvidia_gpu

innovation@innovation-holographics:/usr/sbin$ nvidia-smi
Tue Nov 30 10:07:20 2021
±----------------------------------------------------------------------------+
| NVIDIA-SMI 470.86 Driver Version: 470.86 CUDA Version: 11.4 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 Quadro RTX 4000 Off | 00000000:86:00.0 Off | N/A |
| 30% 34C P8 4W / 125W | 10MiB / 7982MiB | 0% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| 0 N/A N/A 2383 G /usr/lib/xorg/Xorg 4MiB |
| 0 N/A N/A 3332 G /usr/lib/xorg/Xorg 4MiB |
±----------------------------------------------------------------------------+

innovation@innovation-holographics:/usr/sbin$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 4096 x 4096
VGA-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 596mm x 335mm
1600x900 60.00
1280x1024 75.02 60.02
1152x864 75.00
1024x768 75.03 60.00
800x600 75.00 60.32
640x480 75.00 59.94
1920x1080_60.00 59.96*

innovation@innovation-holographics:/usr/sbin$ prime-select query
nvidia

Thanks for any help, and sorry if this an obvious problem, but we’ve tested everything we could find in these threads, with no success…

The matrox driver is a very simple frambuffer driver which doesn’t support any PRIME functions. You can only connect the monitor to the nvidia and configure xorg to use it as primary gpu.

Hello there. I am facing the same problem when installing nvidia 495 on ubuntu 18. Here is my bug report. Can anyone help please?
nvidia-bug-report.log (492.9 KB)

nvidia-bug-report.log.gz (321.6 KB)
Hello @generix, I have 3050 ti graphics card and installed nvidia-470 drivers on ubuntu 18.04. If I select sudo prime-select nvidia, laptop screen shows up but external monitor goes black. If I select sudo prime-select intel, laptop screen goes black external monitor shows up can you help me please?

The nomodeset parameter has to be removed and the stock 5.4 kernel of 18.04 is too old to drive your intel gpu. Please upgrade to 20.04 hwe or use a kernel from liquorix ppa.

Hi everyone,
It seems that I have the similiar problem.
I have a laptap with Ubuntu18.04 and the kernel is 5.4.0-108.I know maybe Ubuntu20 would be better, but for some reason 18.04 must be used.
And when I try to install Nvidia-driver-470 on my laptop(RTX 3060), my GUI disappeared.But I can use the tty1-6 to operate. And nvidia-smi is OK.
I try to solve the problem and have used almost all the methods below in this post,for example:
1. delete /etc/X11/xorg.conf, infact I have not the file.
2. remove nomodeset
3. make sure nvidia-prime and remove nvidia blacklist files
4. switch gdm3 or lightdm
5. change options nvidia-drm modeset=1 to 0

nvidia-bug-report.log (1.9 MB)

This has been bothering me all day. Can someone help me? Thanks a lot!
1 Like

Hi,

I have an Alienware 15 R3 with an Nvidia GTX 1060 GPU (and an intel one as well). I have dual boot with Kubuntu and after installing the Nvidia drivers I cannot boot into Kubuntu normally anymore, and a black screen appears immediately. Weirdly enough, I can log in through the third option in “Advanced Options for Ubuntu”.

I have tried many different things by following forums but it would be too much to share. As main takeaways, I managed to have an external display working with the Nvidia driver (but that is not the case anymore, once I tried fixing the black screen), and both nvidia-smi and nvcc seem to work fine (so does PyTorch with CUDA). The driver is installed and works, but something may be interfering.

I am attaching the bug report. Note that I changed the name but it is still a .gz. Thank you for your help.
nvidia-bug-report.log (327.1 KB)

@generix I have this same issue with a Dell XPS 15 9510 it has an nvidia RTX 3050 Ti, Bios 1.9.0. I need to run ubuntu 18.04 and use nvidia driver due to existing work environment. After installing Ubuntu 18.04 and nvidia driver laptop is rebooted. I get a black screen afterwards and CTRL F1 - F6 does nothing. If there is a fix for this, please share. I understand that Ubuntu 20.04 is working, but I need Ubuntu 18.04 and the nvidia/CUDA libraries/cudnn, etc, etc…

What I did. Fresh install, apt update, apt upgrade apt install ssh, Installed to version 470 proprietary (tested) via Ubuntu’s Software & Updates / Additional Drivers, rebooted, desktop does not load. I can ssh to the laptop though. attached picture and nvidia-bug-report.

Thanks for any help.

nvidia-bug-report.log (1.8 MB)

https://forums.developer.nvidia.com/t/black-screen-after-install-of-nvidia-driver-for-my-ubuntu/210815/3?u=generix

@generix I have the similar problem. Laptop screen not working without external screen plugged. I am attaching log file. Can you please take a look
nvidia-bug-report.log.gz (326.8 KB)

The internal display seems to be detected and used. The lenovo legion has issues with the backlight, did you check if it’s just turned off?