Black screen after install of nvidia driver ubuntu

edidalienware.bin.txt (256 Bytes)
Please save that edid-file as /etc/X11/edid.bin
Then create /etc/X11/xorg.conf only containing

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"
    Option         "ConnectedMonitor" "DFP-0"
    Option         "CustomEDID" "DFP-0:/etc/X11/edid.bin"
    Option         "AllowEmptyInitialConfiguration" "true"
    ModulePath     "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
EndSection
1 Like

I should do it with a kernel 5.8 right?
And, try to install the drivers using
sudo ubuntu-drivers autoinstall
after this?
Sorry, I am kind of a started in all these.

Yes.
You definitely chose the wrong notebook for this. You’re not the first one showing up here with it and so far, this was not working.

I am able to install the nvidia-driver succesfully, but, I am booting into a blank screen after reboot. There is no cursor also, its completly blank.

Please try booting to recovery mode, then commenting out the ConnectedMonitor line

1 Like

Hello, I am testingsns2 from a different account as I reached max replies on previous one.
Even in recovery mode, it is showing the same blank screen

Edit: I reinstalled ubuntu and tried again with the Connected Monitor line removed. Still it is showing a blank screen without anything on the screen.

Were you able to find anythin @generix ?

@generix
I am able to see a blank screen with curson after I connected a second monitor. Now, nvidia-smi command is woring fine when I run it. How can I get the same thing on my laptop default screen, and how to get ubuntu working instead of blank screen with cursor

Edit: I am able to run ubnutu on the second screen. But my primary display is still blank. Whan cal I try for this?

Please create a new nvidia-bug-report.log with the external monitor connected.
Did you check the bios for graphics settings?

1 Like

Here is the new bug report nvidia-bug-report.log (1.2 MB)
Im not surewhat checking graphic setting means. Can you please elaborate on it. I am able to see both Intel UHD and RTX 3070 in BIOS.

Nevermind, I guess this is just a problem with the built-in display, it’s a 300Hz panel. Please check the displays in gnome control center, there you should be able to see the internal screen. Please try changing the refresh rate to 300Hz. At least nouveau is able to use that, maybe the nvidia driver can use that, too.

Even after changing to 300Hz, the primary display is not working.
Also, should I try to make the Inter UHD as the rendered for display?

I’ve been digging for information on this alienware model and it seems Windows users are likewise confused about it.
The internal screen is only connected to the nvidia gpu and also can’t be switched to the intel gpu. Dell ditched optimus for all m15/17 r4 models but incompletely, the intel gpu is still enabled because it drives the USB-C displayport. Kind of a facepalm design, imho.

So it boils down to why the nvidia driver doesn’t output anything on the internal screen while it properly detects it, seems like some odd incompatibility bug. Please send the last nvidia-bug-report.log with a description of the bug to linux-bugs[at]nvidia.com
Maybe that will raise some attention.

Only idea left would be screen brightness, please try lowering it, according to logs, it’s at 100%, and check if you can actually see something on it while it’s black.

Thanks a lot for all the help.
I will mail them the bug report.
I am not able to see anthing on primary display at any brightness level.

I’m also experiencing the same problems with an m15 r4 and an RTX 3070. After installing the 460 nvidia drivers via the update center the internal display stays black although it’s detected. External monitors connected via DP work correctly however. Without the nvidia driver the external monitors don’t work.

One interesting point: When I install the Nvidia driver via a .run script from the nvidia website the internal monitor also works correctly. However, the installation is not really “permanent” and I get random switchbacks to noveau driver after restarting. Any idea what the .run script is doing / not doing differently compared to the “ubuntu driver installer” (via software center / terminal) so that it gets the internal monitor to work?

I’ve attached my bug report output for my current setup.

nvidia-bug-report.log.gz (713.9 KB)

That’s a good lead, you have the same affected 300Hz panel. The main difference is that the .run installer you used is the latest, just released 460.73.01 driver while the repo driver is the older 460.56 driver. So this might be a bug that has been fixed in the latest driver.
The second difference is more subtle, depending on install the Ubuntu repo enables nvidia drm modesetting while the .run installer doesn’t.
Since you’re currently on the repo driver as it seems, please check:
run

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

to find a file containing

options nvidia-drm modeset=1

and change 1 to 0
then run

sudo update-initramfs -u

and reboot.

Thanks for your reply.

Unfortunately setting modesete=0 didn’t fix the issue. Regarding the driver version: I also tried with the NVIDIA-Linux-x86_64-460.39.run about a week ago and this also resulted in a working internal display.

Please post the output of

sudo cat /sys/module/nvidia_drm/parameters/modeset

should be ‘N’ if correctly set.

Output is just:
N

|
|
|
|
|
Editing here since I’m a new user and can’t post more than three times (???):

sudo mv /usr/bin/xrandr /usr/bin/xrandr.backup

didn’t change anything noticeable.

So that’s oviously disabled.
To take xrandr commands possibly called by gpu-manager and the nvidia-prime package out of the equation, please rename it
sudo mv /usr/bin/xrandr /usr/bin/xrandr.bak
then reboot and check if that has an influence.

1 Like