Black screen after installing nvidia-460 driver on Legion 7i laptop (GeForce RTX 2070 with Max-Q)

Looked at the bios updates:

  • 29 Jan 2021: Fix unit will black screen after resume S3 with NV driver 460.79.
    Edit: maybe this is also triggered by the new Linux driver’s power management features and the external screen will just keep it from suspend on boot.

Fantastic news. Where did you look? You mean Lenovo’s bios updates? I’ll look into this and make this forum know.

I did the BIOS update (29 Jan 2021) but the issue remains even though slightly different. The screen is not black now but it get stuck on the LEGION + Ubuntu loading screen.
If I connect a 2nd screen (HDMI) I can see the login screen on the 2nd screen whilst builtin screen is black (but with backlight on).
I tried an apt-get dist-upgrade, I disabled Secure Boot in BIOS. No luck.
I am able to log into the machine via ssh.
What shall I do from here??

ps: I uninstalled nvidia drivers for now and the builtin screen came back. Obviously not what I want but I think it’s important info

Please update SBIOS to latest release and then try with latest nvidia driver.
Will await for test results.

你好,我也遇到了你这个问题,可以方便加个联系方式私聊一下,我的是华硕天选2的,cpu是R7-5800h,RTX3070的显卡,安装了nVidia-460的驱动或者其他版本的驱动重启就是黑屏的想象,试了好多办法都不行

but… that’s what I did in my previous post. I updated to the latest available BIOS (Lenovo Legion 7i) and installed the latest available Nvidia drivers. My previous post reports the result: login screen shows up only when a second (HDMI) screen is connected.; if only the built-in screen is present, it boots but it gets stuck on “LEGION / Ubuntu” loading screen

@spacewarper I’m having the exact same problem you have.(Lenovo Legion 7i / nvidia-driver-460 → Black screen appears on built-in monitor. But second monitor connected with HDMI works fine) Have you solved the problem?

I solved the problem. I hope it helps.


  1. Setting “Dynamic Graphics” on bios menu
    Reboot → enter BIOS by pressing F2 → Select “Dynamic Graphics” → Exit

  2. Install nvidia-driver using “ubuntu-drivers autoinstall”

    sudo ubuntu-drivers autoinstall
    sudo apt-get upgrade
    sudo apt-get update
    sudo reboot
  1. Setting “NVIDIA (Performance Mode)”
    Open terminal → nvidia-settings (enter) → Select PRIME Profiles menu → Select NVIDIA (Performance Mode) → Reboot