Black screen after prime-select nvidia and log out using v346.35 drivers

tried ftp://download.nvidia.com/XFree86/Linux-x86_64/352.09/ ?

Upgraded to Ubuntu 15.04 and facing the same problem as before but my own method does not work anymore :-/.

Kernel 3.19.0-21-generic.

Using xorg-edgers and downloaded driver (any driver from (346-352) causes a black screen and no login. Only console works. Looking at /var/log/Xorg.0.log does not give any clue. I have changed the modeset setting at grub. There is now a login screen, but I am stuck in a log-in loop. So after providing the password it starts all over again. Slowly start to like Windows more :-/

Solved (again :-): Here is a manual to install latest NVIDIA driver on
Ubuntu 15.04, Kernel 3.19.0-21-generic.

  • Download latest Nvidia: I am using ftp://download.nvidia.com/XFree86/Linux-x86_64/352.21/
  • Remove all old stuff: sudo apt-get remove nvidia-* --purge
  • shutdown lightdm with sudo service lightdm stop
  • install downloaded driver 352.21 (I did with DKMS and without 32-comp libs)
  • re-install prime (important) with sudo apt-get install nvidia-prime (original version, not of xorg-edgers)
  • use the xorg.conf below (note that intel and not modedriver is used)

===
Section “ServerLayout”
Identifier “layout”
Screen 0 “nvidia”
Inactive “intel”
EndSection

Section “Device”
Identifier “intel”
Driver “intel”
EndSection

Section “Screen”
Identifier “intel”
Device “intel”
EndSection

Section “Device”
Identifier “nvidia”
Driver “nvidia”
BusID “PCI:1:0:0”
EndSection

Section “Screen”
Identifier “nvidia”
Device “nvidia”
Option “UseDisplayDevice” “None”
EndSection

=====

reboot or restart lightdm

i am on a lenovo Y510p with a 755m and kubuntu 14.04 running 331 nvidia drivers with prime

everything works fine, but i think it is a good idea to move to newer nvidia drivers, tried 352, and i can’t seem to get it to work entirely with the solutions here, i would like to be able to use prime-select (ideally from inside nvidia-settings) to select intel or nvidia graphics

this currently functions on 331

but using the techniques described above it does not seem to want to do this, either it is stuck on intel, or nvidia, and prime-select says no alternates, then trying to add alternates (as described in another location) using /usr/lib/nvidia-xxx-prime/yyy.so as the alternates wouldn’t work because there doesn’t seem to be any folder in that location containing binaries to use.

i am at a loss so any small tidbits would be nice.

oh, to be clear, 331 i am installing from the driver manager utility, where as 352 i was attempting to install from the .run from the nvidia site, as there doesn’t seem to be anything newer than 331 in the repo for ubuntu

Using Ubuntu 14.04.3 with xorg-edgers and the nvidia-355 driver, this black screen issue is now resolved. Yay! Also the mouse cursor disappearing along the top edge of the screen is fixed as well. Someone mentioned the black screen was an xorg-edgers issue instead of an nvidia issue, but to whoever fixed it: Thank you :)

It isn’t fixed for me.

I have tried several different setups and all result in the same issue.

I get a black screen, or I get a lightdm login greeter repeatedly showing up, or it just completely doesn’t set the change so it logs me in, but sets intel as the selected device.

I have tried 14.04 and 15.10 with xorg-edgers and without. I honestly don’t know what else do to and would really appreciate any help, but I would like to use this for some on the go CUDA work.

I have the same problem using Ubuntu 14.04 * 15.04. I have a Dell m4800 with nVidia k2100m w/ Intel HD 5500. I am pretty ready to take a blowtorch to this machine all together and call it quits. The most stressful part is that I can get it to work but it will stop working after around a day. After a fresh clean install of ubuntu everything is great, all 3 of my monitors are functioning. After some updates, a few apps installed(for work… intellij, ect) it will reboot and the monitor connected to the VGA (intel card) is black. Its not turned off, just black, if I bring my mouse to the bottom corner of the 2nd screen I can see the shadow/a few corners of the cursor… its very much turned on.

When that happens the nvidia drivers decide they know best how much to pan around so it will actually start to move my entire desktop screens around by the size of a single monitor. So much for performance/high end workstation machine. Nothing like an entire week+ of productivity destroyed during the last week of a sprint …

I’d like to share my way to solve this problem. imanz90, may be this also will help you. Main suggestion do not use xorg-edgers repository.

sudo apt-get install ppa-purge
sudo ppa-purge xorg-edgers/ppa

And use this PPA:
sudo apt-add-repository ppa:graphics-drivers/ppa

https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-331/+bug/1362848/comments/46

I am still having some major issues with the newest drivers even after performing the recommended fixes. A few things were fixed however which is improvement I guess. This post is long but its a good reflection on the amount of time I have wasted on this issue. I apologize about the tone, if I sound angry its only because this is getting very frustrating and I would really appreciate some help.

What is fixed: Before this latest attempt any time I simply rebooted my laptop while running ANY Linux install the machine would randomly disable Optimus in the BIOS. I am 100% certain of this, I enabled BIOS security to require all changes to need a password, I would enable optimus, boot to Linux, shut down normally and go straight to the BIOS and optimus would be disabled. This seems to be resolved…!

What is NOT fixed: I am still not able to use my external monitor configuration. What will happen is as followed, after following all instructions provided (which I will reiterate below) all 3 monitors work and they work great! Everything seems to be great, what is strange is that the nvidia-settings will only show the two displays connected to DisplayPort but the standard gnome ‘display’ panel will show all 3. This ‘working’ is very very short lived. After using the system for 5 minutes I will perform a restart (this is after the restart for driver install), no other changes had been made. When the system starts up instead of having 3 monitors in extended mode all monitors are setup in mirror. This is not a major concern because I thought maybe after I login it would resolve itself, so I login but nothing changes. I look in the nvidia configuration and the nvidia panel only sees a SINGLE monitor. It does not even see the two DisplayPort monitors, nope just a single monitor. The gnome standard ‘display’ panel does see all 3 monitors and shows that they are in ‘mirror’ mode. Great, easy fix right? No! The second I disable mirror all 3 monitors will turn on, but the display is literally stretched across what seems like all 3 monitors. The resolution is still set to the native resolution in the configuration but literally the display is a single desktop skewed and stretched across all the monitors. What makes this even more frustrating is that the buttons, icons and menus are not actually lined up with were they are displayed so if I want to open the terminal to try and get out of this mode I need to click 3 inches to the left of where the terminal icon is located. If I logout from the OS everything will revert to ALL monitors in ‘mirror’ mode. Here is a few pictures of what this ‘streching’ looks like:
http://imgur.com/a/KOLI5

The best part of this is, I have gotten this EXACT issue with literally every other attempt I have made, using the edgers ppa drivers, different distros, ect.

Here is what I did:
I installed a fresh install of Ubuntu 15.10 and used the drivers available in the ppa:graphics-drivers/ppa repo. To get the machine to not freeze completely at the first screen during install I had to use “nomodeset” in the grub configuration, I did NOT use this after the install. After installing Ubuntu I booted into the OS and made the following permanent changes to the my grub loader:
acpi_osi=Windows acpi_backlight=Vendor

I rebooted the machine while still using the default open source drivers and started on the configuration. First installed all available updates, then added the ppa:graphics-drivers/ppa repo and updated apt-get. Then I installed the following packages:
nvidia-355, nvidia-355-dev, nvidia-settings, nvidia-prime.

After doing this I rebooted the machine and everything worked! All 3 monitors and they were all configured correctly. Now at this point I had already been at this stage at least 8 previous times so I wanted to complete all the other steps outlined here just to make sure this would not all be undone after the next reboot. I followed the steps outlined here: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-331/+bug/1362848/comments/46

At this point I continued to use the machine as normal because I was already home and did not have the energy to replicate my work setup. This morning back at work I boot up my machine, checked the BIOS on start up to make optimus was still enabled (which it was). When the OS launched all monitors were back in mirror mode… and of course the second I disabled mirror mode it was back to the old “stretch across all monitors” configuration…Honestly I am out of ideas… I will try and provide as much information as I can because I would really appreciate anyone’s help.

Let me give a review of my setup. I have a dell m4800 with nvidia k2100 / intel HD 4600 (optimus with software switch in the BIOS). This is not the UHD 4k screen model but instead if FHD (1920x1080) which has true switching optimus. I have no issues with this configuration in Windows 7 Enterprise using just about any drivers. I have a dell docking station and am connected 2 monitors via DisplayPort (native DisplayPort monitors) and the third monitor is connected via VGA (it is also a native DisplayPort but I don’t think my laptop will connect it). The 3 monitors I am using are Dell P2414Hb and each have DP, vga and DVI. For the record I have tried using a DisplayPort hub (MST hub for DP1.2) by connecting all 3 monitors to either the first DisplayPort on the dock or directly to the laptop, in this configuration I was only able to get the first two displays to even recognize in windows so I imagine it is not supported. I was hoping by doing this I would have connected all 3 of my external monitors to the nvidia k2100 which drives the DisplayPorts instead of having one connected to the VGA which I “believe” is being driven by the intel HD card. The hub I used was the following: http://www.startech.com/AV/Displayport-Converters/mst-hub-displayport~MSTDP124DP . Regardless I gave up on that configuration a while ago. I have tried this under many different versions of Linux including ubuntu 12,14.04,14.10,15.04,15.10,fedora 22 and centos 7 with more or less the same results.

EDIT!!: So I just went though all the changes that were recommended in https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-331/+bug/1362848/comments/46 and it seems some of them were reverted? I don’t see how thats possible but regardless I went ahead and made the changes again. The only difference is instead of placing the files into /etc/lightdm and /etc/lightdm/lightdm.conf.d I placed the files into /usr/share/lightdm and /usr/share/lightdm/lightdm.conf.d. I did this because /etc/lightdm/lightdm.conf.d does not exist in Ubuntu 15.10 and /etc/lightdm contains only a single file while all the other lightdm start scripts seem to be in /usr/share/lightdm.

I also went ahead and made the changes previously recommeneded mostly because they were very small impact so I did not see it making anything worse. I edited /usr/lib/primeindicator/igpuon and /usr/lib/primeindicator/dgpuon to contain service lightdm restart right before the sync in both. I also made a change to /sbin/prime-offload by replacing #!/bin/sh by #!/bin/bash (honestly don’t see how this would fix it but either way I made the change).

After I rebooted the machine only a SINGLE of the 3 connected monitors are even recognized by the machine. I have tried checking in the nvidia-settings and the display panel, reconnecting the monitors ect. With these ‘fixes’ in place only 1 monitor is functioning. After this I was playing around in the mentioned files and did notice something interesting, if I just run the /sbin/switch script it runs and returns without any errors but running /sbin/prime-switch gives the following:
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf

So I have no idea whats up…

Hi, I have similar problems while trying to install proprietary NVIDIA drivers.

Setup :

  • Lenovo Thinkpad T540P
  • Ubuntu 14.04 LTS ( kernel 4.2.0-35-generic )
  • GeForce GT 730M + intel graphics controller :
~$ lspci -v | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: NVIDIA Corporation GK208M [GeForce GT 730M] (rev a1) (prog-if 00 [VGA controller])

Problems :

  • If I try to install the drivers via apt I get a black screen instead of the Ubuntu login screen
  • If I try to install the drivers from .run files downloaded from the NVIDIA website there is no black screen but it gets stuck on a loop on the login screen

Things I have tried :

  • removing the xorg-edgers ppa and replacing it with ppa:graphics-drivers/ppa
  • installing different driver versions (331, 346, 352, 356,…) both via apt and via .run files
  • modifying /etc/X11/xorg.conf to use the suggested configurations in this thread
  • editing /sbin/prime-offload as suggested in this thread

I have spent many hours looking up this problem online already, is there any progress on the issue ? A general recommended solution ?

Thanks for your help

I am having this exact issue as well with my GTX-960 and 35-generic. I’ve tried everything you have. The only temp fix is to load kernel 27 to bypass, but I can’t run CIV5.

Did you find any solutions?

Same issue here with a Dell M4800 which shipped with a working Ubuntu 12.04. Upgraded and then re-imaged from scratch with 14.04 and latest Nvidia driver. Now running with nvidia driver from Ubuntu repo and at least I get an image on the HDMI but I have to connect the cable after booting and then select settings->Display before anything appears. Even then it doesn’t always hang around. So this partial success is by removing everything nvidia and then re-installing nvidia and nvidia-prime from the Ubuntu repo (clone thereof). I might have patched any .sh script to use /bin/bash as per another post and then done prime-select nvidia and now I don’t want to switch any more as power is not an issue. On a number of previous tries prime-select query used to return an error regarding update alternatives and only the removal of anything nvidia & re-install got rid of that. It is quite hard to find any i7 laptop that doesn’t have switchable graphics and they even include it on a number of xeons now.