black screen at desktop login [GTX 750 Ti] [390.25]

On openSUSE 42.3 with a GTX650 Ti I have ForceCompositionPipeline=On in the config file and I can see it being logged in /var/log/Xorg.0.log. My system is working well with none of the previously described symptoms.

Hello all!

I had the same issues with 390.25.4-1 on Quadro 1000M/openSUSE Leap 42.3/KDE Plasma 5.8 LTS (SDDM fails to start), 390.25.10-1 fixes that issue but I have new ones:

  • system freezes when I try to start NVIDIA X Server Settings;
  • I’m experiencing small freezes with the applications or compositing on some desktop effects (e.g. cycling between the tabs in Chrome or using Alt+Tab for switching between the applications).
    P.s. also high CPU on moments.

HotMusicFan: Before 390.25-10.1, my desktop was behaving in a similar manner to your description. At that time I also noticed NVRM “Graphics Exception” errors in the output of
“sudo journalctl -n 1000”.

It might be worth looking in ~/.xsession-errors-:0 , /var/log/Xorg.0.log and maybe also the output from sudo

Well, from “sudo journalctl -n 1000” I don’t have such an errors; as a regular user I checked the other logs but I don’t know what to look for in them. I’ve generated an archive with the bug report and I’ll send it to the specified email.
Also I realised that I can no longer play locally saved videos because the computer freezes again. :/

After struggling with this error since 390.12 was released, I solved it today. It turned out that the 390 drivers were conflicting with residual 384 ones. I dpkg removed all 384 modules, reinstalled 390.40, and it works fine.

In case this helps anyone else…

Issue still not fixed for me with drivers 390.42, kernel 4.15.7. But if it’s not working because of some 384 drivers remnants, then I’m unsure what to do since I don’t use fedora package manager to install/remove the drivers (I’m using the .run from nvidia).

I also use the .run programs, but to install not remove.

The removal method I used was :

dpkg -l NV (lists all installed packages that include “NV”)
dpkg -l nv (same, making sure I found all of them in case)

Several 384 nvidia packages were listed.

dpkg -r package name (removes the packages; dpkg will tell you if there are dependencies, and I had to remove them in the allowed order to get rid of them all.

I didn’t try the .run --uninstall option.

Unless it concerns nvidia-modprobe, which is for me the only installed package (390.25 version) that dnf can find related to nvidia, then it is still not working.
Well, anyway, removing nvidia-modprobe didn’t fix the issue (instead Blender lose the ability to use CUDA). Maybe I have to wait until nvidia-modprobe in Fedora updates to 390.42, but if it is something else, I’m still stuck with the problem.
I didn’t try the --uninstall option either since 390.25, could be a possible fix.

I’m having this exact problem, on a GTX 750 Ti. Fedora/4.15.10-300.fc27.x86_64/Xorg11/GNOME. Just did a dnf up and I’m now getting just a black screen after logging in. I haven’t got any ForceComposition options goin’. Really stuck without a paddle, at the moment.

@sgtlion : If you don’t have the line Option “metamodes” "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On} in /etc/X11/xorg.conf or ForceCompositionPipeline checked in nvidia-settings when you’re experiencing this issue, I’m not sure you have the exact same problem we have here. As for me, without those lines, no problem / with those lines, every 390.xx driver will cause a black desktop (I can still see my cursor).
Just for me to know, can you retrieve your desktop by switching back from a console to your desktop ?

I don’t have the metamodes line, and the ForceCompositionPipeline setting ain’t ticked, so perhaps it is a different issue. However, after a bit more experimenting, the issue does only happen to me with 390.xx drivers, and I seem to be able to get to my Desktop by switching logging into tty and 'xstart’ing, so phew, that’s something.

I did manage to get things sorted out regarding xorg with CompositionPipeline enabled on boot by deleting the secondary display position values in the displays.xml file for xfce in /home/XXXXX/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml (deleting that file also works).

When ever the position for the secondary monitor in displays.xml, was set to the same x and y position value in xorg.conf, provided by the nvidia driver, the black screen would appear upon boot with {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On} in xorg. Though it doesn’t occur with compositing disabled (as you all know), with any driver previous to v390, or when non-matching x and y position values are used for secondary display with it enabled.

The specific numbers for myself are +0 +120
Xorg entry:

“metamodes” “DVI-I-1: 2560x1440_60 +1920+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DVI-D-0: 1920x1200_60 +0+120 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}”

and displays.xml entry:

<property name=“DVI-I-1” type=“string” value=“1. Samsung 24"”>

<property name=“DVI-D-0” type=“string” value=“2. Samsung 24"”>

I would suggest to delete your DE’s display properties file (if applicable), to confirm this isn’t an isolated incident.

Thank you skrall666. This issue is finally solved here for me with your solution. Since I don’t use multiple monitors (right now), I suppose it was some remnants from some previous configurations or old monitors I used.

This bug has reappeared again.

GPU: GTX 1060
OS: Fedora 29 64 + XFCE
NVIDIA drivers 410.73
Kernel: 4.18.16-300.fc29.x86_64

I’m not using compositing - just a plain old X session.

Could you also try the solution in post #32 by skrall666 ? That did the trick for me.

I’ve deleted displays.xml and now everything works.

However I believe NVIDIA drivers have a bug which needs to be fixed.

This issue is not fixed. No idea why it’s marked this way.