Black Screen & Cannot enter terminal

My original posts are here and I had to open a new one due to new users cannot post more than 3 replies in a thread.

So here’s my problem: I tried to install the Nvidia driver on my Ubuntu 18.04, but after reboot, I lost the GUI and cannot boot into the system. I tried following several solutions from posts, but right now I can not even enter the terminal via Ctrl+Alt+F1/F6/F7. I have tried Alt+PrtScreen+r and Alt+F4, but it’s not working either. I did try the recovery mode, but the only output is:

Loading ubuntu 5.4.70-generic...
Loading initial ramdisk...

and it’s not responding to any keyboard input, including Ctrl+Alt+F1/F6/F7 and Alt+PrtScreen+r

Right now my question is: is there any other way to enter the terminal and generate the bug report? @generix @Mart

Thanks for your guys’ help!

Are there any ealier kernel version available on grub menu?

Yes. I tried 5.4.60-generic, it’s not working either.

Please try editing the kernel parameters in grub menu, removing quiet splash, does it show more then?

Yes it’s allowing me entering the terminal
But it keeps switching between the terminal login page and some code and made it very difficult for me to enter commands. Any idea of how to fix this?

Sounds like systemd is restarting the Xserver over and over, please wait for up to ~3 minutes until systemd gives up.

Thanks for your help! It worked.
Here’s the new bug-report:nvidia-bug-report.log-05070143.gz - Google Drive

FYI, I have taken a snapshot of the code that is continuing popping out:

Mesa is always crashing the Xserver:

May 07 09:31:26  (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x139) [0x5603e51a1199]
May 07 09:31:26  (EE) 1: /lib/x86_64-linux-gnu/ (funlockfile+0x50) [0x7f9706e359cf]
May 07 09:31:26  (EE) 2: /usr/lib/x86_64-linux-gnu/ (_init+0x9fec) [0x7f96fca5447c]
May 07 09:31:26  (EE) 3: /usr/lib/x86_64-linux-gnu/ (_init+0x127be) [0x7f96fca654ce]
May 07 09:31:26  (EE) 4: /usr/lib/x86_64-linux-gnu/ (_init+0x18cff) [0x7f96fca71e3f]
May 07 09:31:26  (EE) 5: /usr/lib/x86_64-linux-gnu/ (_init+0x1222b) [0x7f96fca64d7b]
May 07 09:31:26  (EE) 6: /usr/lib/x86_64-linux-gnu/ (_init+0xe19d) [0x7f96fca5ccfd]
May 07 09:31:26  (EE) 7: /usr/lib/x86_64-linux-gnu/ (_init+0xe1e5) [0x7f96fca5cd85]
May 07 09:31:26  (EE) 8: /usr/lib/x86_64-linux-gnu/ (_init+0x7f68) [0x7f96fca50778]
May 07 09:31:26  (EE) 9: /usr/lib/xorg/modules/ (glamor_egl_init+0x9d) [0x7f970046639d]
May 07 09:31:26  (EE) 10: /usr/lib/xorg/modules/drivers/ (_init+0x558c) [0x7f97010ecbcc]
May 07 09:31:26  (EE) 11: /usr/lib/xorg/Xorg (InitOutput+0xc79) [0x5603e50851b9]
May 07 09:31:26  (EE) 12: /usr/lib/xorg/Xorg (InitFonts+0x1dd) [0x5603e504807d]
May 07 09:31:26  (EE) 13: /lib/x86_64-linux-gnu/ (__libc_start_main+0xe7) [0x7f9706a53bf7]
May 07 09:31:26  (EE) 14: /usr/lib/xorg/Xorg (_start+0x2a) [0x5603e5031eaa]

which is odd. For ease of debugging, please disable gdm:
sudo systemctl disable display-manager
so you should always end up on tty without grub fiddling. After login, you can test the Xserver by running
sudo systemctl start gdm

For mesa crashing I can imagine two reasons:

  1. broken mesa update received
  • try updating the system
  1. incorrectly packaged nvidia driver packages
  • please uninstall the nvidia driver, remove the graphics drivers ppa, then check if the Xserver comes alive on intel only.

Here are the commands I executed and the system’s outputs:

$ sudo systemctl disable display-manager
output: Nothing

$ sudo systemctl start gdm
output: Nothing

$ sudo apt-get remove nvidia*
$ sudo apt autoremove

output: 4xx MB data has been removed

$ sudo prime-select intel

output: prime-select command is not available

reboot(with no change in kernel parameters)

output: jumping very fast from ubuntu loading screen to black screen

reboot(with quist splash removed from kernel parameters)

output: quickly switching between terminal entering the page and the code same as the previous post, and the system gives up switching after ~3 minutes, entered terminal.

When the terminal is entered, there is a line saying failed to connect to an address related to the mesa. Unfortunately, I forgot to take a picture but I am sure it contains the word mesa in the address

Then I tried sudo apt-get update, it’s saying that it failed to connect to the server and cannot finish the update. I tried modifying the servers in \etc\apt\sources.list, but there are still 256 packages that failed to update.

Last, I tried a reboot but it’s black screen again, even with the quiet splash removed from the kernel parameters. I tried replacing the quiet splash with nomodeset but it’s not working either. Recovery mode is not working as well.

Looks like your system is really broken, if it even fails with the nvidia driver removed. Does the black screen go away if you wait?
If not, please try booting a 18.04 live from usb thumbdrive and post the output of
cat /proc/partitions

Hi It’s me again

I didn’t want to spend too much time repairing the broken system so I did a reinstall via a bootable USB disk. The reinstall of 18.04.5 was a success and then I installed the Nvidia 460 driver via Software and Updates in Ubuntu(with a GUI), it succeeded as well even after I reboot it. All the things were working perfectly. I was very happy and installed other software I would like to have, such as ROS and Nvidia-docker.

Nevertheless, this morning I booted into Windows and when I tried to boot into Ubuntu again, I got a black screen again. No response to Ctrl+Alt+F1/F6/F7 and recovery mode failed as well. This time I did not do a single command after it broke, so I assume this time my system will not be as broken as last time.

Would you like to tell me ways to enter the terminal? I tried fiddling the kernel parameters, including remove “quiet splash”, adding “nomodeset” and replace “quiet splash” with “nomodeset”, but none of them can help me enter the terminal and generate the nvidia-bug-report.

Note: One of my update posts had been hidden by the system, though I don’t know why. If you still can’t see the hidden post when you are reading this, just keep in mind that I just reinstalled the ubuntu system, installed the Nvidia driver, works fine, then experienced black screen again.


I just rebooted the system and fortunately, I got in with a GUI, and everything works fine. I still generated a Nvidia-bug-report in case the black screen issue happens again.

the bug report

There’s another small issue I want to bring up: whenever I boot into one of the systems and then boot into the other, say from windows 10 to ubuntu or from ubuntu to windows 10, before I am connected to the internet, the time shown is always 8 hrs ahead of my current time. I am in the timezone that has GMT+8, but the time shown is still 8 hours ahead, until I connect to the internet and time will back to the right one. However, if I do not perform the system switching, even if I reboot, the time will be correct after the reboot finish. I am not sure what caused this or if this is related to the black screen issue.