Black screen on boot, Ubuntu 20.04 [kernel 5.8.0-43], GeForce GTX 1050 Ti

I’m using a GeForce GTX 1050 Ti with a Gigabye GA-E7AUM-DS2H motherboard (BIOS F4 08/26/2009, is latest) and Ubuntu 20.04.1 [kernel 5.8.0-43-generic]. It’s a pretty vanilla installation, right now – I’ve used the “Minimal installation” option. I’m using nvidia-460.39.

My problem is that, when connected to my LG TV with my Onkyo receiver, ( TV <-hdmi-> Onkyo <-hdmi-> computer), it boots to a black screen. If I connect directly to the TV ( TV <-hdmi-> computer), then I don’t get a black screen and the Ubuntu GUI seems to be working fine (gdm3).

I enabled debugging by adding “Enable=true” in the “[debug]” section of /etc/gdm3/custom.conf

I’ve tried using the nomodeset option in GRUB, but that didn’t seem to affect this.

When it boots to a black screen, I am unable to use Ctrl-Alt-F1, etc., to get to a terminal. When I use that key combination, nothing happens. However, I can log in remotely via ssh, which I did to produce the attached nvidia-bug-report.log.gz

I’m hoping to figure out how to configure my system so that I may boot properly while connected to the Onkyo receiver.

nvidia-bug-report.log.gz (296.9 KB)

X is starting fine, the receiver is detected and a 4k@60 mode is set. So not really anything in the logs why you don’t see anything.
What’s the exact Onkyo model? Did you try with a v450 driver?

The receiver is an Onkyo TX-NR585. I have tried the 450 driver and seen the same behavior as described for 460. I just tried it, again. The specific driver version is 450.102.04 Once it booted to the black screen, I generated a new nvidia-bug-report.log.gz (415.0 KB)
To be clear, I still wasn’t able to get a terminal with Alt-Ctrl-F1, I had to log in via ssh.

Here’s more info that I should’ve included in the first place. This is a dual-boot machine. My other OS is Ubuntu 14.04.2 using nvidia driver v430.26. With booted into 14.04.2 I don’t have this problem while connected to the receiver. In other words, with the desired connection [ TV <-hdmi-> Onkyo <-hdmi-> computer ], the computer boots to the GUI and is responsive – it does not boot to the black screen.

This may be unrelated, but I have noticed that, when using the Ubuntu 14.04.2 setup, sometimes (unpredictably) when I turn the receiver off, wait a while, turn it back on, the computer GUI is unresponsive. When this happens, I log in via ssh and reboot it. Sometimes, when I turn the receiver off, wait, and turn it on, I can switch to another HDMI input, then switch back to the computer’s HDMI input and it will be responsive.

In case it’s helpful, here’s nvidia-bug-report.log.gz (1.0 MB) from that setup.

It has occurred to me to try v430.26 with Ubuntu 20.04, but it didn’t appear to be available.

I also tried using v390 with Ubuntu 20.04 and I got the black screen, again. Here is the nvidia-bug-report.log.gz (258.0 KB) from that attempt.

When I rebooted using the direct connection [ TV <-hdmi-> computer ] using v390, the GUI froze after several minutes. Here’s the nvidia-bug-report.log.gz (259.5 KB) via ssh while it was frozen. (I forgot to try Ctrl-Alt-F1 that time )

Please try this, run

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

to find a file containing

options nvidia-drm modeset=1

and change 1 to 0
then run

sudo update-initramfs -u

and reboot.

I did not find a file with that setting in it.

$ grep -Hn nvidia /etc/modprobe.d/* /lib/modprobe.d/*
/etc/modprobe.d/blacklist-framebuffer.conf:18:blacklist nvidiafb
$ sudo find /etc -type f -exec grep -Hn nvidia-drm '{}' \; | wc
      0       0       0

So, I went ahead and created a file (/etc/modprobe.d/nvidia.conf) with the setting and tried it out

$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-5.8.0-43-generic
I: The initramfs will attempt to resume from /dev/dm-1
I: (/dev/mapper/mythbuntu--vg-swap_1)
I: Set the RESUME variable to override this.

Unfortunately, that also resulted in booting to a black screen. I logged in via ssh and created the file nvidia-bug-report.log.gz (375.7 KB)

I deleted my new file and ran sudo update-initramfs -u, again. I am underthe impression that should put me back to nvidia-drm modeset=1.

I also decided try that via a temporary edit of GRUB settings at boot. I added nvidia-drm.modeset=0 at the end of the line “linux /boot/vmlinuz…”. Not too surprisingly, that also gave me the black screen on boot. Via ssh, I generated the file nvidia-bug-report.log.gz (377.6 KB)

Finally, it occurred to me to look for a Onkyo firmware update. There was a pending update for my model, however, it didn’t fix the problem. My Onkyo firmware is now at 1071-2000-1070-0011 dated 14-Jan-2021. Just in case, I also generated the file from the black screen in this case. nvidia-bug-report.log.gz (475.8 KB)

The default value of nvidia-drm modeset is 0. You could try setting it to 1 instead.

I created /etc/modprobe.d/nvidia.conf containing options nvidia-drm modeset=0. I did sudo update-initramfs -u and rebooted. My old friend the black screen greeted me, again. I logged in via ssh and generated nvidia-bug-report.log.gz (414.8 KB)

I’ve also found that if I boot while connected directly to the TV (TV <-hdmi-> computer) so that I avoid the black screen, I may then, without rebooting, switch the HDMI connection to the receiver ( TV <-hdmi-> Onkyo <-hdmi-> computer) and the display continues to work just fine.

I’m happy to try any further suggestions…

I have a suspicion on what’s happening. You’re booting using CSM meaning initially, simple VGA resolution is used. So maybe the receiver gets irritated by that and then denies further function. Already tried using an EFI install?

Is that the same as UEFI? I’m pretty sure my motherboard doesn’t have UEFI.

Yes, your mainboard is too old for that, so that was a wrong lead.