Black screen on multi-monitor setup on Xorg with driver > 525.60.11


I have a laptop using and AMD CPU+GPU and a discrete NVIDIA GPU.
In very short, I have this setup:

Monitor 2 ← DP cable → Monitor 1 ← USB C → Laptop

When using Xorg and a newer version of the driver > 525.60.11, Monitor 1 does not work.

The behavior is very strange. If I disable monitor 2, monitor 1 works.
Re-enabling monitor 2 makes monitor 1 show a partial frame.
Then, the two of them stop working at random while making the other work. Sometimes.

I really cannot figure out what is the issue at all.

Running Wayland has no issue, the monitors work perfectly.
It is just that Plasma is not very Wayland-friendly and a bit unstable.

I am attaching the log generated from the “nvidia-log-report” script.

Other information that can be useful
OS: ArchLinux, all packages up to date
Desktop Environment: Plasma 5.27, happens also in GNOME
Kernels: Both 6.1.19 LTS and stable 6.2.6

Current workaround
Downgrade the driver to 525.60.11.
The driver however does not work with the stable kernel, only the LTS one.

Let me know if I can provide more information!
nvidia-bug-report.log.gz (2.1 MB)

1 Like

While the symptoms are completely different, I suspect your issue to have the same reason as this:
DisplayPort bandwidth too low.

Hi @generix,

I appreciate your input.
I looked quickly through the thread and the main difference is that Wayland for me works with no issue.
It might be that the driver misbehaves with clocks only in Xorg…?

I can try the “Prefer maximum performance” trick and report back.

Would you like me to gather other information?

Quick update:
Setting the NVIDIA card mode to “Prefer maximum performance” via NVIDIA X Settings still has the middle screen as black.

It seems however that, sometimes, disabling and enabling the middle screen gets to work.
It involves disabling all external monitors, then enabling monitor 2 and then monitor 1.
The mode needs to be maximum performance and this won’t survive a reboot AKA this disabling and enabling process need to be reapplied.

Hello, I tried using the newest driver 530.41.03, both proprietary and open version.
For a short period of time, all monitor work, but then the two DP monitor just will stop refreshing themselves.
Even with a single monitor, it does not get refreshed properly.

I am attaching a screenshot that show what the system sees (all good with no problem) and what I see (parts of windows and monitors not refreshing).
I will also attach the new log.

There was a Xorg config to enable debug messages, should I do that?

nvidia-bug-report.log.gz (709.9 KB)

I have also degraded experience in Wayland with the latest drivers. I cannot move windows between monitors without the whole thing panicking and resetting over 15 seconds.
Here is a video of the issue:

I’m having the same issues with any driver over 525.60.11 too on Ubuntu 22.10 on Xorg. One screen remains black or with a frozen frame. I have a laptop with intel 12700h with integrated graphics and a nvidia 3070. The laptop monitor runs on the integrated intel gpu and the 2 external monitors run on the nvidia card via display port, but I also tried one monitor via hdmi and the issue still reproduces. Sometimes, even the second monitor freezes besides the first one being blank.

I am asking by directly replying to you seeing you are being very active.
Given the major issue and the fact that I am forced to use the old drivers with such behavior, do you have any recommendation for escalating the issue?

Not sure if this is helpful, but this sounds a bit like my bug

The problem appears to be in DP / USB-C(?) daisy-chaining which it sounds like is what you’re doing. My bug didn’t get any traction, and I’m still using my workaround of just not daisy chaining.

The flash to black thing in your video is precisely what I would see. However, none of my monitors would get screwed up frames. I haven’t retested the newer drivers since I report my bug, but from your report it sounds like nothing has been fixed.

The new 535.x drivers solve all issues! Finally :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.