Black screen on Ubuntu startup with blinking cursor after upgrade

Hello, thank you in advance for your help. I know there are many threads about similar topics to this, but none have worked, trust me I have tried them all!

Ubuntu prompted a system update, including Nvidia drivers, through the GUI, I clicked accept and it updated in the OS. After the update, I could not view images, with the error message:

/lib/x86_64-linux-gnu/ undefined symbol: hb_glib_script_to_script

The update prompted a restart, so I did, hoping it would fix it. After that, it would not start, and i get the infamous flashing cursor on a black screen. I can access the terminal by doing Ctrl + Alt + F2, and everything seems OK, it just will not load the main OS.

I tried so many solutions online, but I think I have narrowed down my problem to something very specific. After reinstalling Nvidia drivers multiple times, I tried to run nvidia-settings and now get the error messages;

/lib/x86_64-linux-gnu/ undefined symbol: hb_glib_script_to_scrip cannot open the shared object file: No such file or directory
/lib/x86_64-linux-gnu/ undefined symbol: hb_glib_script_to_script cannot open the shared object file: No such file or directory

Now this is the same error message I got when trying to open an image earlier, so narrows down further it is a graphics issue. However, after some googling, it seems the package libharfbuzz has something to do with this hb_glib_script_to_script business.

Here is where I might have made a mistake: I remember trying to reinstall/install a package called libharfbuzz, but I can’t remember the reason. I downloaded a tar.gz of this package, and did the ./configure and sudo make install. After whatever I did there a couple of weeks ago, I left it, and nothing bad has happened since then.

Some things I have tried:

  • reinstalling all drivers
  • loading the old kernel in GRUB
  • changing GRUB settings including using nomodeset
  • reinstalling libpango-1.0-0 and libharfbuzzb0 packages using apt install

Currently Ubuntu is unusable for me. Please help if you can. I am happy to provide more info if it is needed.