black screen with 367.35

Hi

simply black screen when run kde (kf5) with 367.35

back to 367.27 works
nvidia-bug-report.log.gz (222 KB)

Got the same too on other WM/DE, but a switch to VT1 and back fixes it.

Can confirm, the same problem is occurring here (using blackbox or any other WM).

Can NOT confirm. The newest 367.35 driver works as expected with my GTX850M (Optimus with some Intel) and KDE (+SDDM).

same black screen with LXQT. switch & back the VT not fix the problem

Happens to me with the { ForceFullCompositionPipeline = On } metamodes option in my xorg config. Removing the option fixes the black screens issue but will no doubt have reintroduced screen tear. I believe other metamodes options are the cause of the same issue.

This !

I had to go back to the previous version :(

Same here.

Running dual screen setup, secondary screen turns black.
Having static xorg.conf setup:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-1: 1920x1080_144 +0+0, HDMI-0: nvidia-auto-select +1920+0 {rotation=left}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Curiously running xrandr --off and --auto hot fixes the problem:

xrandr --output HDMI-0 --right-of DVI-I-1 --rotate left --off
xrandr --output HDMI-0 --right-of DVI-I-1 --rotate left --auto

@tpruzina I bet if you remove {rotation=left} it’ll work.

Yeah, but I like my secondary monitor pivoted. Also, it works just fine with 367.27 e.g. it’s a regression that needs to be fixed.

Oh, thanks for the temporary fix.

happens also to me. (openSUSE Tumbleweed x86_64, KDE Plasma 5.7.1, KDE Frameworks 5.24.0, Qt 5.6.1)

i workaround it by going to VT8 and then back to VT7.
but it is annoying.

Can confirm bug with optimus laptop with GTX850M running Ubuntu 16.04 (Unity).

Booting into nvidia graphics or switching from intel graphics leaves me with a black screen.

Has it ever worked prior to 367.35 drivers? If not then you should google for how to deal with Optimus support on linux (drivers README section regarding randr offloading would be a great start, or “bumblebee nvidia”).

Hello,

I am also encountering problems with this version, 367.27-1 worked great. I run a dual-gpu, triple-head setup with the following static xorg-conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 367.35  (builduser@rw)  Fri Jul 15 21:07:27 CEST 2016

....

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "GPU-1.DFP-1, DFP-0, DFP-1" # Added manually. Not the problem ...
    Option         "metamodes" "GPU-064cee27-a87d-eb28-080e-9bc72e8108aa.GPU-0.DP-2: nvidia-auto-select +1024+128, GPU-064cee27-a87d-eb28-080e-9bc72e8108aa.GPU-0.DP-3: nvidia-auto-select +2304+128, GPU-45f0e424-af3b-927b-d72c-d00dc9f3136b.GPU-1.DP-3: nvidia-auto-select +0+0 {rotation=left}"
    Option         "MultiGPU" "Off"
    Option         "SLI" "off"
    Option         "BaseMosaic" "on"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Metamode on boot:

$ nvidia-settings --query CurrentMetaMode

  Attribute 'CurrentMetaMode' (archbase:0.0): id=50, switchable=no, source=nv-control :: DPY-2: nvidia-auto-select @1280x1024 +1024+128 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0}, DPY-3: nvidia-auto-select @1280x1024 +2304+128 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0}, DPY-9: nvidia-auto-select  @1024x1280 +0+0 {ViewPortIn=1024x1280, ViewPortOut=1280x1024+0+0, Rotation=90}

When I boot my machine, the leftmost (GPU-1.DFP-1/DP-3, DPY-9; the rotated one) display is black, but reported ON from xrandr and nvidia-settings (GUI) and in the metamode query above. Now when I change the rotation to ‘None’ within the GUI, the display starts working and switching back to ‘Left’ makes it work like it should.

I tried to temporary fix it at first using xrandr as suggest above. I derived that script from a ‘fixed’ working setup (achieved with the method described above) with the graphical interface arandr. The result should be equal to the above metamode:

#!/bin/sh
xrandr \
--output GPU-0.DP-0 --off \
--output GPU-0.DP-1 --off \
--output GPU-0.DP-2 --mode 1280x1024 --pos 1024x128 --rotate normal \
--output GPU-0.DP-3 --primary --mode 1280x1024 --pos 2304x128 --rotate normal \
--output GPU-0.DP-4 --off \
--output GPU-0.DP-5 --off \
--output GPU-1.DP-3 --mode 1280x1024 --pos 0x0 --rotate left \
--output GPU-1.DP-2 --off \
--output GPU-1.DP-1 --off \
--output GPU-1.DP-0 --off \
--output GPU-1.DP-5 --off \
--output GPU-1.DP-4 --off

But this gives quite crazy results with a totally screwd virtual display plus one monitor is always off. Usually it is one of GPU-0, but I think the order is what matters here.

I thought maybe I can automate the switching back and forth in the GUI via the command line directly and tried to set the metamode via nvidia-settings:

$ nvidia-settings --assign="CurrentMetaMode='id=50, switchable=no, source=nv-control :: DPY-3: nvidia-auto-select @1280x1024 +2304+128 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0}, DPY-2: 1280x1024 @1280x1024 +1024+128 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0}, DPY-9: nvidia-auto-select @1024x1280 +0+0 {ViewPortIn=1024x1280, ViewPortOut=1280x1024+0+0, Rotation=90}'"

This leads to black screen on DPY-3. When I query the metamode again, it returns:

$ nvidia-settings --query CurrentMetaMode -t
id=50, switchable=no, source=nv-control :: DPY-2: 1280x1024 @1280x1024 +1024+128 {ViewPortIn=1280x1024,ViewPortOut=1280x1024+0+0}, DPY-9: nvidia-auto-select @1024x1280 +0+0 {ViewPortIn=1024x1280, ViewPortOut=1280x1024+0+0, Rotation=90}

One can see that it is not correctly assigned. The now-black (DPY-3; first mentioned) display is missing. Why?

Even more funny is the following:

[00:09:36] $ nvidia-settings --query CurrentMetaMode -t
id=50, switchable=no, source=nv-control :: DPY-2: 1280x1024 @1280x1024 +1024+128 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0}, DPY-3: 1280x1024 @1280x1024 +2304+128 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0}, DPY-9: nvidia-auto-select @1024x1280 +0+0 {ViewPortIn=1024x1280, ViewPortOut=1280x1024+0+0, Rotation=90}

[00:19:12] $ nvidia-settings --assign="CurrentMetaMode='$(nvidia-settings --query CurrentMetaMode -t)'"

[00:20:42] $ nvidia-settings --query CurrentMetaMode -t
id=50, switchable=no, source=nv-control :: DPY-3: 1280x1024 @1280x1024 +2304+128 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0}, DPY-9: nvidia-auto-select @1024x1280 +0+0 {ViewPortIn=1024x1280, ViewPortOut=1280x1024+0+0, Rotation=90}

Assigning the exact current reported metamode fails, like above, leaving the first mentioned display with black screen. It seems like the ordering is critical.

But at all, there is something wrong with parsing or setting the metamode, or something in that regard. If set via xrandr or command line, the first mentioned display is always omitted. Currently only the GUI has the power to activate all three displays at the same time, as described in the beginning.

A complete error log generated with nvidia-bug-report.sh can be found here.

Thanks for reading, regards.

Ok apparently running nvidia-settings --assign CurrentMetaMode=“what i have in xorg.conf” post login works just fine. Pretty lame workaround but at least I can get rid of this awful screen tearing.

Thank you. It is working - with all 3 monitors!

Using the metamode format from xorg.conf works. Question remains why it doesn’t if you provide the format reported from nvidia-settings?

I thought it may work like this before trying all the other stuff above, but then I saw the ‘terse-output’ option provided by nvidia-settings and thought that it’s output should be valid input. Did not bother to try it out with the xorg.conf metamode string.

Following command is working for my setup:

$ nvidia-settings --assign CurrentMetaMode="GPU-064cee27-a87d-eb28-080e-9bc72e8108aa.GPU-0.DP-2: nvidia-auto-select +1024+128, GPU-064cee27-a87d-eb28-080e-9bc72e8108aa.GPU-0.DP-3: nvidia-auto-select +2304+128, GPU-45f0e424-af3b-927b-d72c-d00dc9f3136b.GPU-1.DP-3: nvidia-auto-select +0+0 {rotation=left}"

@tpruzina

Yes.

I installed the package from https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa .

I had no issues with previously packaged drivers from this ppa.

I mentioned the issue to the ppa mainteiner and he replied they only package the driver so I should report the bug to nvidia.

I can confirm all of these reports.

MetaMode “extra attributes” as specified in Chapter 12 of the README are broken when specified in xconfig files in this latest release. You have to use the nvidia-settings command after boot to apply those options. Really annoying for those of us who rely heavily on ForceFullCompositionPipeline.