Black screens on GTX 1070 Mobile

Hi all,

I’m on Arch Linux (technically Antergos, but updated daily) with a Sager NP8153, with a GTX 1070 Mobile.

Randomly multiple times a day my screens will go black. There seems to be no rhyme or reason to it, I don’t have to be doing graphics intensive things, even writing in libreoffice or just being in Chrome can cause it. It does seem to happen most often while doing video conferences though.

I’ve checked my GPU temperature while it’s been happening, and have run gpu_burn, but the GPU stays around 47-50 degrees. I also verified that all fans are running while the laptop is on.

In the logs, there’s an error:
kernel: NVRM: Xid (PCI:0000:01:00): 79, GPU has fallen off the bus.

I’ve tried disabling monitor sleeping in case it was acpi (just through gnome power settings), downgrading the nvidia driver from 381.22-3 to 375.66, tried nvidia-beta in AUR, have disabled G-SYNC, flipping, and vblank, and added rcutree.rcu_idle_gp_delay=1 to my grub menu due to a forum post I found, but they seem to have no affect.

I’m at a loss, and imagine it to be a hardware issue, but just thought that I’d check here first. Thanks!

I’ve tried with both a blank Xorg.conf file and the newly generated installed Xorg.conf file from the nvidia installer.

I also tried briefly to get nouveau working, but it wouldn’t launch X so I gave up rather quickly.

I’m using an external monitor, and both screens turn off completely.

Also, I’ve had the laptop for about a year, but the problem just recently started happening…I’d say within the last two weeks.
nvidia-bug-report.log.gz (276 KB)
Xorg.1.log (109 KB)
xorg.conf.txt (1.29 KB)

log messages.txt (14.9 KB)

Doesn’t look so good:
https://devtalk.nvidia.com/default/topic/984339/?comment=5046689

This can be hardware issue too. Check with vendor support.

>> Also, I’ve had the laptop for about a year, but the problem just recently started happening…I’d say within the last two weeks.
Any recent change in your laptop? Check there is no any power and thermal issue to system and gpu when this issue hit. Is the issue hit in battery mode[AC] or in power plugin[DC] mode also? What desktop env you are running kde, gnome or else? Please share output of dmidecode command and url showing specs of your laptop.

Thanks, I’ve started the process of talking to sager/lpcdigital. I think that I’ve actually proved that it’s hardware now because the monitors also blank out in Windows 10, windows is just able to recover from the error.

No, no hardware changes. I’ve also tried running it without any usb devices plugged in thinking it might cause the issue, but the same thing happens. I haven’t actually tried it on only battery, it’s been plugged in the whole time. Is it worth a try?

I run gnome.

Also, sorry, but I don’t see a URL listing specs, lpcdigital doesn’t sell this model currently, and sager’s are pretty customizable. Here’s my specs from the order:

Display: 15.6” Full HD (1920 x 1080) Clear LG IPS MATTE G-SYNC™ Technology
CPU / Processor: 6th Generation Intel® Core™ i7-6700HQ (6M Cache, up to 3.50 GHz)
Video & Graphics Card: NVIDIA® GeForce™ GTX 1070 GPU with 8GB GDDR5 NVIDIA PASCAL™
Thermal Compound: IC Diamond Thermal Compound - CPU + GPU ($35.00)
Memory: 32GB Dual Channel DDR4 2400MHz (PC4 19200) Memory (2 x 16GB) ($135.00)
M.2 SSD RAID Storage Options: Non-RAID Storage
M.2 SSD Drive Slot 1: SanDisk X400 512GB M.2 SSD - (OS Drive) ($85.00)
M.2 SSD Drive Slot 2: None
Primary Hard Disk Drive: 1 TB HGST 7200 RPM SATA 6Gb/s Hard Drive
Hard Disk Drive 2: None
HDD Raid Settings: Off
Wireless Network Card: Intel® Dual Band Ultra -AC 8260 M.2 AC + Bluetooth 4.2 Combo Card
AC Power Adapter: Full Range AC-in 100~240V, 50~60Hz, 230W AC autoswitch Adapter
Primary Battery: Embedded 4 cells Polymer battery pack 60WH

dmidecode.txt (17.4 KB)

Just wanted to add a final note for anyone else having this issue…this was hardware for me, a bad graphics card. Sager replaced it, seems to be fixed now. The fact that it happened in both windows and linux was pretty telling that it was hardware. Thanks for the help, all.