Blast repeating bug

Hi,
I’m trying out the blast feature and noticed the blasted pieces keep repeating. I’m applying a force to have a sphere collide on the cube. Have attached a video to showcase. Is this a bug?

Here’s my Machinima version:
image

Hello @qazs! I’ve asked the dev team to look into this. I appreciate you informing us of this!

Hi @qazs, that is definitely a bug. I’ll try reproducing it with that version of Machinima and then ensure that it’s fixed in later versions.

Hi again @qazs, I tried to recreate this in Machinima 2022.2.1-rc.1, but so far I don’t get the behavior in the video. Could you attach a usd(a) file of the scene you used? Thanks.

Also, could you tell me which version of omni.blast you’re using?

Here’s the file: Blast.usda (1.4 MB)

Using this version:

Thank you for the info and the file. I assume that for you, running the file shows the “repeating” bug. For me, when I run the file the block falls a short distance and fractures fairly invisibly. I’ve attached a video showing its behavior. I’m not sure what’s going on. I see that Machinima 2022.3.0 uses the most recently published omni.blast extension, if you’re keen on updating. There’s been an extensive update done on the damage model in 0.11. Blast now uses a stress solver to calculate damage spread. This unifies the way damage is handled with impact, user-appled, and now additionally with gravity and centrifugal forces. That is, structures can crumble under their own weight if the supporting pieces aren’t strong enough. Check out the documentation for details.

Hi, I see in your video the sphere did not move, I think you didn’t enable the Force field extension. There’s a force applied to it and it should move and hit the wall. Also in Machinima, the Blast extension is not the latest version, there’s no option to upgrade. Do I have to wait for the new version of Machinima to use the latest extensions?

Hi, you’re right, it wasn’t enabled. With it enabled I can reproduce the issue. Evidently blast isn’t playing nicely with force fields. Unfortunately I can reproduce it in the latest Machinma+omni.blast too. Regarding updating extensions, extension versions are locked with each release of Machinima (or Create).

I’ll file a ticket and we’ll get to the bottom of it. Thank you for reporting this.

Thanks for looking into this. Noticed collisions resulted from force fields are not very accurate, not only blast. Also I get varying results when rendering from path trace and real time using the same values. For example in real time mode, a sphere can hit a cube by applying a force, but in path trace the sphere flies through the cube. Seems like force in path trace is stronger? Hope this can be fixed.

Interesting. My guess is that this is down to frame rate, leading to a greater possibility of tunneling with slower frame rates. And the variability of frame rate could lead to different impact positions when an object is subject to a force. Just speculation; you might want to open a new ticket specifically for those issues. But if that is the problem, there are settings which allow you to prevent tunneling (CCD - Continuous Collision Detection) and also to set a fixed simulation frame time (along with # of subdivisions per frame).