Blender 3.4.0 v102 Crashes every time I use Boxcutter

This didn’t happen with 3.4.0 v101 to me.

I realize Boxcutter is not your add-on, but it is a very popular add-on.

Just to be clear, when I says crashes, I mean Blender closes and you lose your work.

I am going to uninstall and put 101 back on and verify it works with 101 in case I just didn’t try it.

1 Like

I just verified this. v101 does not crash, so something you did between 101 and 102 is messed up. I also tried uninstalling v102 and putting back on in case something corrupted last time. Same result.

Steps to reproduce the error if you have Boxcutter:

  1. Create a UV Sphere (I haven’t tried other types yet).
  2. Click on one of the axes like x, y or z.
  3. Make sure Sphere is selected an Activate Box Cutter.
  4. Begin to draw rectangle and Blender goes Poof. Goodbye.

If you need any log files or anything, tell me where they are and I can send them to you.


Hello @DataJuggler! I’ve reported this issue to the dev team to fix. I appreciate you letting us know about this!

A development ticket was generated from this post. OM-72579: Blender 3.4.0 v102 Crashes every time I use Boxcutter

Hi there!

Would you be able to test the issue in a newer Blender build like the 3.4 Beta or the 3.5 Alpha? Our build doesn’t touch much outside the USD importer and exporter, so it’s possible this is a bug in the main Blender build.


I will test when I get off work. It is just strange to me it happened between v101 and v102.

I downloaded the latest 3.4 version today from

Version 3.4 crashes the same way, so it must be on their end. How do I report this to Blender? Do you happen to know?

Hi @DataJuggler! Do you know what version of Boxcutter (version 7.19.14) you are running? Here is a link to the Blender Support page: Support —

I contacted Blender, and Blender told me to contact the Add On maker.

I had, I just updated to and Blender 3.4 still crashes.

I will let the Add On Maker know.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.