Blue Screen after flashing Tegra B-PX2, after rebooting | need help

We are getting Blue screen after flashing Tegra B-PX2. Cannot log-in or perform any activity.

After re-flashing Tegra-B, it worked for a few hours, but now the TEGRA-B is giving Blue screen and some times flicker.
Tegra-A is working fine (not re-flashed).

Need urgent help.

Some more details:

  • We (me and RatheeshR) can operate the Tegra via minicom normally, but we get this recurring message when accessing the Tegra via minicom
    [ 467.071694] user pgtable: 4k pages, 39-bit VAs, pgd = ffffffc175539000
    [ 467.073949] [00000000000000e0] *pgd=00000001efc2a003, *pud=00000001efc2a003, *pmd=0000000000000000
    [ 467.077346] Library at 0x7f737096e4: 0x7f736bd000 /usr/lib/aarch64-linux-gnu/libnux-graphics-4.0.0
    [ 467.080597] Library at 0x7f73709678: 0x7f736bd000 /usr/lib/aarch64-linux-gnu/libnux-graphics-4.0.0
    [ 467.083798] vdso base = 0x7f81a96000
    (repeat)
  • After rebooting via minicom, we can again see the login screen, but the blue screen occurs right after login.
  • after changing our /etc/apt/sources.list, then running sudo dpkg --configure -a, the recurring message went away and we were able to login normally. we recommend running, after this,
    sudo apt-get upgrade -f
    sudo apt-get autoremove
    sudo apt-get upgrade
    sudo reboot

Via minicom, we replaced the file /etc/apt/sources.list with these contents:

Ubuntu Main Repos

deb [arch=arm64] http://ports.ubuntu.com/ubuntu-ports/ xenial main restricted universe multiverse
deb-src [arch=arm64] http://ports.ubuntu.com/ubuntu-ports/ xenial main restricted universe multiverse

Ubuntu Update Repos

deb [arch=arm64] http://ports.ubuntu.com/ubuntu-ports/ xenial-security main restricted universe multiverse
deb [arch=arm64] http://ports.ubuntu.com/ubuntu-ports/ xenial-updates main restricted universe multiverse
deb [arch=arm64] http://ports.ubuntu.com/ubuntu-ports/ xenial-proposed main restricted universe multiverse
deb [arch=arm64] http://ports.ubuntu.com/ubuntu-ports/ xenial-backports main restricted universe multiverse
deb-src [arch=arm64] http://ports.ubuntu.com/ubuntu-ports/ xenial-security main restricted universe multiverse
deb-src [arch=arm64] http://ports.ubuntu.com/ubuntu-ports/ xenial-updates main restricted universe multiverse
deb-src [arch=arm64] http://ports.ubuntu.com/ubuntu-ports/ xenial-proposed main restricted universe multiverse
deb-src [arch=arm64] http://ports.ubuntu.com/ubuntu-ports/ xenial-backports main restricted universe multiverse

Dear liyu5,

Thank you for your detailed update.
Could you please let me know if you have still blue screen issue after applying the above you mentioned?

The blue screen issue was fixed after running sudo dpkg --configure -a

Dear liyu5,

Thank you for your update.