Bluetooth Audio Working but not Microphone

Hello, having trouble with my headset (specifically a sony wh-1000xm3)

I set up Bluetooth audio based on the instructions here:
https://docs.nvidia.com/jetson/l4t/index.html?fbclid=IwAR1a-D2CK7yZ4P7SiPfkbgtkDO5Q0ejtRTQyO8aP3FnOcqd0rS6ZTztGijA#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide%2Fhw_setup.html%23wwpID0E0DN0HA

However, the mic on the headset does not work. This is the bluetooth dongle I’m using https://www.amazon.com/Sabrent-Bluetooth-Adapter-Technology-BT-UB40/dp/B06XHY5VXF

If anyone has leads on drivers that I may need to download or whatnot it’d be appreciated. I can’t seem to find anything in NVIDIA’s documentation or the forum here so I’m a bit lost!

Not sure (and have no experience with bluetooth audio), but I’ve seen this topic today that might help.

1 Like

Definitely a step in the right direction. Thanks! Doing a pacmd list-sources revealed this

...       
 index: 3
	name: <bluez_sink.CC_98_8B_49_E6_0D.a2dp_sink.monitor>
	driver: <module-bluez5-device.c>
	flags: DECIBEL_VOLUME LATENCY 
	state: IDLE
	suspend cause: 
	priority: 1050
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	fixed latency: 45.32 ms
	monitor_of: 2
	card: 2 <bluez_card.CC_98_8B_49_E6_0D>
	module: 29
	properties:
		device.description = "Monitor of WH-1000XM3"
		device.class = "monitor"
		device.string = "CC:98:8B:49:E6:0D"
		device.api = "bluez"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_CC_98_8B_49_E6_0D"
		bluez.class = "0x240404"
		bluez.alias = "WH-1000XM3"
		device.icon_name = "audio-headset-bluetooth"
		device.intended_roles = "phone"

Hello!

Does the following work …

$ pacmd play-file <wavfile> bluez_sink.CC_98_8B_49_E6_0D.a2dp_sink.monitor

Also do you see the bluetooth device under the Desktop UI Sound Settings menu? If so you should be able to select the device there as the default playback device. You can also use ‘pacmd’ to set as the default device as well.

Regards,
Jon

I didn’t try the terminal command you posted but my issue isn’t with playback. I’m able to hear sounds but I can’t use it as a microphone for, say, a Zoom call. It even shows up under the input. However, talking produces no audio

For those that find this post in the future I was not able to find a solution. I needed this to work so regrettably I’ll be getting rid of my Nano. My best guess is that it has something to do with the input not being detected in ALSA (arecord -l).

These are the things I tried:

  • Setting the input to the “Headset” option (screenshot above)
  • Increasing input level to max
  • Setting default source (pacmd set-default-source)
  • Setting source port (pacmd set-source-port)
  • Sanity check to make sure the microphone on the headset was working, which it was

Hope that helps someone in the future solve this!