Bluetooth bring up for Jeston XAVIER

Dear all,

I’m working with AP6236 module for WIFI AND BT. WIFI already worked well so I move to BT part.
But I could not find much information about the BT on Jetson Xavier. We are connecting BT to UART5 same as the reference design.

It seems like bluedroid_pm module is using for BT and it is insmod automatically when system finish booting.
Lsmod result as below

nvidia@kms-master:~$ lsmod
Module Size Used by
fuse 118987 3
zram 30081 8
nvgpu 1719775 18
binfmt_misc 14730 1
bluedroid_pm 16187 0
ip_tables 21475 0
x_tables 38080 1 ip_tables

Rfkill list result

nvidia@kms-master:~$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: brcmfmac-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
2: bluedroid_pm: Bluetooth
Soft blocked: no
Hard blocked: no

When I tried to run hciconfig -a, it showed nothing.

Do I have to insmod the other module to enable Bluetooth on XAVIER.
Any recommendations would be much appreciated.

Thanks,

Hi,

Are you sure there is no extra firmware needed for bluetooth? What driver do you use for this module?

Hi Wayne,

Thank for your reply.

After downloading the firmware for Bluetooth module, I could use the Bluetooth module as well.
The download command

brcm_patchram_plus -d --enable_hci --no2bytes --tosleep 200000 --use_baudrate_for_download --baudrate 1500000 --bd_addr “11:22:33:44:55:66” --patchram /lib/firmware/brcm/BCM4343B0.hcd /dev/ttyTHS4 &

Best Regards,