Bluetooth HCI0 Bug

My team is developing a small point scan Raman imaging system and we used to use a Raspberry Pi 4 to send data via bluetooth. On the RPi4 we would use the following commands before making the connection to improve throughput on a bluetooth low energy connection:

echo 6 > /sys/kernel/debug/bluetooth/hci0/conn_min_interval
echo 20 > /sys/kernel/debug/bluetooth/hci0/conn_max_interval

However, these no longer work on this NVIDIA Jetson Xavier NX kit. I’ve tried creating them but even as root, permission is always denied. Changing ownership or performing a chmod to attain full rights doesn’t seem to change that.

Are these advanced bluetooth parameters exposed somewhere else? Am I missing something?

I’ve run ‘find . -type d | grep bluetooth’ to find all the bluetooth related files thinking it might be somewhere else but I can’t seem to find it anywhere.

Would really appreciate any information. It’s hard to find it anywhere online.

This is my current setup:

Distributor ID: Ubuntu
Description: Ubuntu 18.04.4 LTS
Release: 18.04
Codename: bionic

Linux 4.9.140-tegra #1 SMP PREEMPT Wed Apr 8 18:15:20 PDT 2020 aarch64 aarch64 aarch64 GNU/Linux

Wifi/Bluetooth Card: AW-CB375NF

● bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
Drop-In: /lib/systemd/system/bluetooth.service.d
Active: active (running) since Mon 2020-06-22 18:29:54 EDT; 3h 45min ago
Docs: man:bluetoothd(8)
Main PID: 5577 (bluetoothd)
Status: “Running”
Tasks: 1 (limit: 4915)
CGroup: /system.slice/bluetooth.service
└─5577 /usr/lib/bluetooth/bluetoothd -d --noplugin=audio,a2dp,avrcp

Also tried adding the following to the nv-bluetooth-service.conf file:


And then running ‘sudo /etc/init.d/bluetooth restart’ and ‘systemctl daemon-reload’, but that didn’t work either.

Sorry for the late reply.
Is this still an issue?

No, it’s okay. I returned it.
Thank you