Bluetooth speaker not connecting automatically to jetson nano

i have successfully paired bluetooth speaker to my jetson nano and it connects if i connect manually from bluetooth option. i want the speaker to connect automatically when jetson switches on.
should i add/change anything in the bluetooth config file? or how can i do it?

Hi siddharth,

Please refer to below section to see if can help:

hi kayccc,
i tried this before but still no luck.
is there a way to change the default audio settings?
i wanna set my bluetooth speaker as the first priority

Please refer to topic