Board no longer boots, fan doesn't spin. What can I do?


I am new to these forums. I recently purchased the Xavier NX and followed the getting started guide. Everything seemed to work and I was brought into the desktop screen. After just a couple minutes I was prompted to do a restart to complete the installation. The board restarted on it’s own 3-5 times and would deliver the same message about my web-cam, keyboard, and mouse not being loaded?

Now when I power the board, my display doesn’t turn on and the lights on my keyboard do not turn on. There is a solid green light signaling power that is lit.

I tried re-formating and flashing my SD card two times. I read somewhere that I should connect this thing using UART, but that I need to be using a native linux operating system. (Ubuntu Guest OS on my Windows 10 computer does not seem to work)

Could someone give me some things to try in order to bring this board back to life? I’m hoping getting that UART access will at least let me get information off of the board… Please help!

Here is an update with my UART serial dump. I spent all day figuring out how to get this serial dump. Please help me!

[0000.024] W> RATCHET: MB1 binary ratchet value 4 is too large than ratchet level 2 from HW fuses.
[0000.033] I> MB1 (prd-version:
[0000.038] I> Boot-mode: Coldboot
[0000.041] I> Chip revision : A02P
[0000.044] I> Bootrom patch version : 15 (correctly patched)
[0000.049] I> ATE fuse revision : 0x200
[0000.053] I> Ram repair fuse : 0x0
[0000.056] I> Ram Code : 0x0
[0000.058] I> rst_source : 0x0
[0000.061] I> rst_level : 0x0
[0000.065] I> Boot-device: QSPI
[0000.067] I> Qspi flash params source = brbct
[0000.071] I> Qspi using bpmp-dma
[0000.074] I> Qspi clock source : pllp
[0000.078] I> QSPI Flash Size = 32 MB
[0000.081] I> Qspi initialized successfully
[0000.085] E> No bootable slot found
[0000.089] E> LOADER: Failed to get slot for boot chain from SMD.
[0000.094] E> LOADER: Failed to get storage info for binary 0 from loader.
[0000.101] E> LOADER: Failed to get info for binary 0 from loader.
[0000.106] C> LOADER: Could not read binary 0.
[0000.110] C> Fail to load mb1-bct bin
[0000.114] E> Task 24 failed (err: 0x1d540102)
[0000.118] E> Top caller module: LOADER, error module: AB_BOOTCTRL, reason: 0x02, aux_info: 0x01
[0000.126] I> MB1( BIT boot status dump :
[0000.156] I> Reset to recovery mode


Have you tried sdkmanager to flash your board yet?


Thank you for the reply. I did. I spent a lot of time trying to get minicom to work for me and took the time to create a dual boot for Ubunut 18.04 LTS in efforts to get the uart serial dump. While I was there, I tried to run the sdkmanager. It detected my board when I plugged it in, which seemed promising. I followed the prompts and let it execute. The software it wanted to load for the host machine (I assume my Ubunutu) completed successfully. The flash failed for the target HW. All of the software it wanted to load after the flash failed as well.

I was able to get the UART using an Arduino Uno by the way. It was much easier than minicom in my opinion. I also did not understand that the GPIO pins do not contain the UART for the actual chip itself. I only discovered by chance that the UART Pins are under the heat sink!

Let me know if there is any more information I can provide!

Thank you again.


Hi Cameron,

Please refer to this page and share both the host log and device log.



I attempted to run the script that is referenced in the tutorial you provided, but unfortunately I do not know what arguments I should provide it. The example in the tutorial shows how to run the script using the tx2i. If you could provide me with the arguments I should use for Xavier NX devkit, I can run this script and get the logs for you.

I decided to try flashing again using the sdkmanager GUI instead. I exported the log file for the failed installation, please see attached. Maybe the log you are looking for can be found in this exported file?

I also ran the installation with UART connected to capture the serial dump during the flash, however, nothing ever displayed. I think my installation failed before reaching the part where it actually flashes the board.

SDKM_logs_JetPack_4.4_Linux_for_Jetson_Xavier_NX_[developer_kit_version] (110.7 KB)

I think the flash failed because my drive is formatted to FAT32, I am going to reformat the drive and retry.


In fact we put every document on the dlc. Thus, you could check this page if I cannot reply you in time.

You could check the quick start guide.

And the arguments are just the *.conf file name under Linux_for_Tegra. For example, for sdcard NX module, you need to use jetson-xavier-nx-devkit.conf so the parameter is jetson-xavier-nx-devkit.

Thus the command is

sudo ./ jetson-xavier-nx-devkit mmcblk0p1

1 Like


I had to re-install my Ubuntu dual boot because I configured it incorrectly for using sdkmanager. sdkmanager successfully flashed my Xavier NX and the board is now working again. Thank you for your assistance!