Boot Error on AGX Xavier after apt-upgrade. Jetpack:4.5.1

Hello I am using an AGX Xavier Developer Kit. I flashed it to JetPack 4.5.1 and gives an RAMDISK error after I run the sudo apt-get upgrade. I checked the other topics on same issue but the only official solution is upgrading the JetPack version.
In my situation, I am using Leopard Imaging IMX577 cameras and 4CAM adapter board. Cameras’ drivers are working only on JetPack 4.5.1 so need to make my AGX Xavier work on JetPack4.5.1.
Is there a solution on this? Any help will be appreciated. Thanks in advance.

Error message:

hello huseyinarslan.ceng,

how to install JP-4.5.1? did you use apt upgrade or you’ve fresh image flashing?

Hello JerryChang thank you for your answer.
I installed JetPack both using SDK Manager and ./flash.sh seperately. Same error occured after I run apt upgrade.
At the end of the apt upgrade command there is a warning: “Couldn’t identify filesystem type for fsck hook, ignoring”
Also when I run the update-initramfs -u there is an error like this.


I am wondering that if this is the main cause of the booting issue.
Thanks

Hi,

What do you want to do now? This ramdisk issue is resolved in jeptack4.6, and some patches are not public source so we are not able to share to you.

Hello,
As I noted in first entry, the driver of cameras I bought from Leopard Imaging works on only JP4.5.1, I am wondering any idea to solve this issue.

Hi,

Reflash your device to jetpack4.5.1. Remove nvidia related apt server from your apt source list on your jetson.

Then your apt-get upgrade won’t hit this error anymore.

Thank you for your answer, I will try soon.