Boot failure due to network driver

I have two Nano’s that both have the same problems.

I am using the recommended USB power adapter (rated at 5.25v / 2.5 a). Both using 16GB SD card formatted using the Windows instructions.

  1. This issue is FYI: Both failed to display anything during boot. Switching from DP to HDMI resolved this issue.

  2. Current issue: nVidia splash screen is displayed followed by kernel load log.

However, both Nano’s crash during “Started Network Manager Script Dispatcher Service”.

I’ve tried booting with and without a network cable attached - same result: crash.

I’ve tried warm booting after the crash occurs - same result.

I’ve attempted to enter into grub but no luck there.

I can’t answer the question on failure, but there is no GRUB in an embedded system. It uses U-Boot instead. Since there is no BIOS/UEFI for embedded the bootloader must handle all of the content the BIOS would normally set up.

In terms of the actual error I’m sure whoever answers will want a serial console log and dmesg content to narrow down the issue. Video failure can never be used as a sign of boot failure, but it sounds like you have an actual crash message.

Hi, john_bowker

Could could try with a larger card?
And if there is a picture captured when it boot failed will be helpful to analyze the root cause.

And also be helpful to share the flash tools and some information about that.

I returned to this today - changing the SD card to 64GB solved the problem. I’m now using a Samsung EVO Select 64GB.

Thanks!

Glad to hear that it is resolved.