bootfromUSB not working after install Arducam driver

Can you just take a picture on your monitor and let me see what does your log look like?


i think it is same. i don’t understand what you need.

Ahh… can you put your terminal into full screen, reboot the device and dump the log again?

For example,

This is the log you shared

[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pa4

But actually the full line should be like below

[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 1023544

(this is from my jetson nano)
All of your lines are not full one in your log file.

Nano_UsbBoot_05.txt (71.4 KB)
i got it. i changed full hd monitor.
this is full screen log. you may see what you want.

Nano_UsbBoot_00.txt (22.1 KB)
this is the log able to boot of device. but have some problem of getting image of imx477.
you can refer.

Just want to tell you that your log file is still being cut.

The kernel command line is still not full.

But I can see the cause of your issue now, your root device looks like still mmcblk0p1. This is the default node for sdcard. But appears that sdcard does not exist on your board so it is not able to find the rootfs.

[ 6.584544] Root device found: mmcblk0p1
[ 8.088769] scsi 0:0:0:0: Direct-Access Samsung Flash Drive FIT 1100 PQ: 0 ANSI: 6
[ 8.097569] sd 0:0:0:0: [sda] 501253132 512-byte logical blocks: (257 GB/239 GiB)
[ 8.105234] sd 0:0:0:0: [sda] Write Protect is off
[ 8.110193] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
[ 8.127453] sda: sda1
[ 8.130936] sd 0:0:0:0: [sda] Attached SCSI removable disk
[ 16.742326] ERROR: mmcblk0p1 not found

You can learn by reading this post to understand what gets missing on your board now.

A simple solution is put your sdcard image back, let it boot into filesystem.

Then, you mount your sda1 to a mount point by using mount command. Goes to the your_mount_point/boot/extlinux/extlinux.conf and add root=/dev/sda1 to the kernel command line. Reboot and see if it helps.

But again, you need to get the full log so that we can see the kernel cmdline.

Nano_UsbBoot_07.txt (72.5 KB)
then, how about this?

Kernel command line: tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,4 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1

Yes, do as what I suggested.

Nano_UsbBoot_08.txt (21.8 KB)
Nano_UsbBoot_09.txt (21.5 KB)
here.

Remove the quiet inside extlinux.conf so that the kernel log will be printed. Currently, this is silent mode.

Nano_UsbBoot_10.txt (157.3 KB)
OK, here you are.

It looks like you can login now. The last comment is waiting for you to enter info

Ubuntu 18.04.6 LTS Nano ttyS0
Nano login: user
Password:

Also, it looks like you are using UUID to locate the file system now.

[ 7.963029] Rootfs mounted over PARTUUID=17c0943d-d8d6-47aa-b945-dce49ad99fd4

Is this done by you or you also don’t know where is came from?

yes, i can login now.
current log is that editing sdcard’s extlinux.conf to UUID of USB.
then i can boot using sdcard and usb memory both, not only usb.

it it different from you suggestion?

Nano_UsbBoot_11.txt (78.8 KB)
sorry, i edited by /dev/sda1.
result maybe same.

It is ok. UUID or sda1 both indicate the usb drive.

BTW, the more precise way to describe this:

Currently the kernel is loaded from the sdcard, and this kernel mounts the file system from your usb.

It does not “boot from both”. It boots from the sd.
We use where the kernel located to say where it boots.

yes, it is booted from sdcard.
then, what i do?