Booting error after update of Geforce 3060 driver to 515.48 in ubuntu 20

I am getting loading initial ramdisk error after updating drivers for Geforce 3060 from 495.23 to 515.48 in ubuntu 20. I have to update the drivers for carla simulator and unreal engine and now I am stuck.

Please help me!!
Thanks in advance

Hello @ms.sona.12, welcome to the NVIDIA developer forums.

Can you switch to a different terminal using CTRL+ALT+F1 or any other Function key from F1 through F6.

There you will find console terminals where you can log on to the machine and first of all backup your important data.
(I suppose the comment Issues booting up Ubuntu OS with Nvidia GeForce RTX 3060 - #3 by ms.sona.12 was from you and referring to this post here?)

Then you can change your boot mode in grub to not boot into the GUI but console mode only. You can find a lot of tutorials online on how to do that. Then no NVIDIA kernel modules are loaded that cause issues with the installation process… Then you should do a fresh install of the new driver. Which means

  • Purge all existing NVIDIA drivers
  • Run sudo update-initramfs -u
  • Reboot
  • Install the new drivers
  • Runsudo update-initramfs -u
  • reboot
  • Run nvidia-smi to check if the GPU is recognized correctly
  • Only then revert the changes in grub to get your GUI back.

After that let’s see if there is still an issue.

I hope this helps.

no I am not able to switch to console modes as far as I can understand. I can access grub menu and go to advanced recovery menu.
How to remove all NVIDIA drivers I don’t understand. And I am also skeptical that if I remove all driver it might affect the system as system has dedicated GPU .
Can you please guide me how to purge all existing NVIDIA drivers from grub menu itself?

Thanks for reply. I have already invested more than 20 hours to get rid of this error.

I would be grateful if u can help me out.

If you can go to advanced recovery then you should also be able to open a shell, correct? A normal terminal or console. If you get there then you can also use that. Otherwise I recommend reading up about how to disable booting into the GUI by default, for example on askubuntu.

Once you have a shell/terminal/console open, start by making sure no nvidia modules are loaded

sudo lsmod | grep nvidia

If there are still modules loaded, unload them with sudo modprobe -r and the name of the module. You might need to do it in certain order. Then uninstall the nvidia driver for example with

sudo apt-get purge nvidia*
sudo apt-get autoremove
sudo update-initramfs -u
sudo reboot

Reboot and get back into a shell. Now install the NVIDIA driver you want to install. Make sure to follow the instructions of the installer exactly! If you have secure boot enabled you MUST follow the correct authentication process, otherwise the kernel module will not be loaded.

After the installation you can re-enable the boot to GUI.

I am getting this screen. Do I need to set anything as shown or I can go ahead with reboot ?

Thanks for reply.

Can you first check the output of

dpkg --list | grep -i  nvidia

Did you install the NVIDIA driver using dpkg? That would also explain the problems especially if the old driver was installed using a different method. It is recommended to use either the driver package provided with Ubuntu (you can check that with nvidia-detector or use the GUI software manager, look for 3rd party applications). Or you download the .runfile from NVIDIA and use the built-in installer.

I have not installed anything. This is the output of the command.