Booting issue with combo "Seeed A203v2 + TX2-NX"

Dear Jetson community !

I went into issues with TX2-NX SOM + A203v2 carrier board.

I followed this tutorial, and started flashing emmc through command line :

As Seeed explained, I applied patchs to L4T R32.6.1 package by replacing :

  • tegra186-mb1-bct-pinmux-p3636-0001-a00.cfg
  • tegra186-p3636-0001-p3509-0000-a01.dtb.

Here is the flash.sh log
log-27022022.txt (33.8 KB)
.
I managed to have the TX2-NX booting Ubuntu right after flashing process.
But after a power on-off cycle, comes back to nvidia logo stuck.

I reFlashed several times (same command), but same results.

I saw, this boot unreliability issue with A206 (Leetop A206 Carrier Board boot issues & boot unreliability based on temperature - #2 by ningxuemao2005).
Is there same sort of issue with A203v2 ?

Someone experienced same combo “Seeed A203v2 + TX2-NX” ? and with which results ?

Thanks,

The log says you already flashed the board without error.

If the problem is you got stuck during boot, you should share the uart log.

I don’t know if this custom board has any port on it. Maybe you can consult with the vendor.

Thank you WayneWWW,

I consulted the vendor forum, still waiting for an answer.

Here is the log at boot time thanks to USB-TTL dongle :
log-boot.txt (2.9 KB)

Thank you.

There is no boot problem of A206 in the hardware design of A203.

Hi @utilisateur580 ,

It looks like you are able to dump the uart log but you just tried the wrong ttyUSBx. Please change one and dump again.

And I am not sure what is @ningxuemao2005 tried to say here. No one is blaming the hardware has any problem, this customer just wants to know which port is used to dump the uart log…

In A203 hardware design, UART2 serial port signal has no external level conversion IC. The actual test found that some products of tx2-nx module need the RX signal pin238 of UART2 to be connected to the level conversion chip to start normally, otherwise they will be stuck on the navdia logo all the time. You can try this connection, which is equivalent to connecting the 3.3V level switching IC with pin 238, so that it can start up. This should be the issue of tx2-nx module.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.