Booting logo , login logo custom

Also, I have said that you need at least python 3.10, but you still got python 3.8.
If you cannot handle it, use docker.

Previously, an error occurred while performing the following steps:

Was it because of the Python version?

After installing Python 3.10

edkrepo clone nvidia-uefi NVIDIA platform main

It’s in progress

I wanted to create an nvidia folder with SDK Manager to see if that would be the problem.

I feel like you don’t know how all these things work at all.
You should really use docker.

export EDK2_DEV_IMAGE="ghcr.io/tianocore/containers/ubuntu-22-dev:latest"

I want to use Docker, but I need to use Ubuntu version 20.04.

Is there any problem if I change the above command to 20.04?

docker image has nothing to do with your host OS…
Do you really know what docker is for?

You’d better do some research before asking some very very basic questions.

who knew everything, would I ask something as basic as this?

I’m asking a question because I couldn’t find it on my own.

I am asking this question because it is very different from when setting up Xavier NX.

I know the basics of Docker images, and the manual explains version 22.04, but I want to install 20.04, so I’m asking if there will be any problems if I install 20.04.

I understand that Docker operates as an image that is used regardless of the host PC.
I am inquiring because I would like to install version 20.04 on Orin Nano.

The docker image is only for building the UEFI binary, and is not what’s going to be installed on your Jetson device.
Are you fine with it?

I reinstalled Ubuntu 20.04 on my laptop and tried again, but the boot logo did not change.

Build with docker at

edk2_docker edkrepo manifest-repos add nvidia https://github.com/NVIDIA/edk2-edkrepo-manifest.git main nvidia

mkdir test

edk2_docker edkrepo clone test NVIDIA-Platforms uefi-202308.1
cd test/nvidia-uefi
edk2_docker edk2-nvidia/Platform/NVIDIA/Jetson/build.sh

After building like this, I changed the bmp and built again.

Did you replace the UEFI binary?
(Linux_for_Tegra/bootloader/uefi_jetson.bin)

no
I can’t find a way to change it.

Please tell me how to change it

SDK Manager
The created folder is
/nvidia/nvidia_sdk/jetpack_5.1.1_Linux_jetson_orin_nano_targets/Linux_for_Tegra/bootloader/uefi_jetson.bin
I am on the above path. Is this correct?

Come on, bro.
How would you expect it to take effect when you don’t even replace the file…
Is it really that difficult for you?

YES.
There is a file called uefi_jetson_RELEASE.bin in the build folder of UEFI source (I don’t remember the exact name, and please find it yourself.); replace the original uefi_jetson.bin with this uefi_jetson_RELEASE.bin. Remember to rename it.

~/test/nvidia-uefi/images/uefi_jetson_RELEASE.bin
Rename UEFI jetson.bin
/nvidia/nvidia_sdk/jetpack_5.1.1_Linux_jetson_orin_nano_targets/Linux_for_Tegra/bootloader/uefi_jetson.bin

Is there any problem if I do this and flash it with SDK Manager?

NO.
Exactly what you need. Please go ahead.

uefi_jetson.bin
After replacing the file
The board screen does not appear after flashing.

After changing to an existing file
After flashing, it boots normally.

uefi_Jetson_DEBUG.bin There was an instruction to copy the file.
Nevertheless, the problem was not resolved.

Even if you delete all the contents of the file and try again with Jetpack version 5.1.2, the result is the same.

Should I do this?

You could replace the uefi_jetson.bin under Linux_for_Tegra/bootloader/
and use the following command to flash bootloader only.

$ sudo ./flash.sh -r -k cpu-bootloader jetson-agx-xavier-devkit mmcblk0p1

jetson-agx-xavier-devkit → jetson-orin-devkit ?

sudo ./flash.sh -r -k A_cpu-bootloader jetson-orin-nano-devkit internal

sudo ./flash.sh -r -k A_cpu-bootloader jetson-orin-nano-devkit internal

error message
Error: return value 4
Command tegradevflash_v2 --write A_cpu-bootloader uefi_jetson_with_dtb_sigheader.bin.encrypt
Failed to flash/read t186ref.
came out

sudo ./flash.sh -r -k jetson-orin-nano-devkit internal

*** Update [jetson-orin-nano-devkit] is not supported. ***

The above message appeared, but no error occurred.
The screen is still not displayed.