Booting Problem After Reconfiguring nvidia-l4t-bootloader

My AGX device experienced the booting problem from a recent update. I went through the fix instruction listed below:

  1. reboot the device 7 times,
  2. the device should be able to boot up properly.
  3. edit the /boot/extlinux/extlinux.conf to do following changes: - APPEND {cbootargs} quiet + APPEND {cbootargs} root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
  4. Reboot the device, and run “dpkg-reconfigure nvidia-l4t-bootloader”
  5. reboot the device.

However, although I could boot the device after 7 reboots. The boot problem showed up again after I run “dpkg-reconfigure nvidia-l4t-bootloader”. Meanwhile, my extlinux.conf has the correct argument all the time (there is no “APPEND {cbootargs} quiet” in it).

Any ideas and thoughts would be appreciated.

Thanks in advance.


sudo apt update
sudo apt dist-upgrade -y

(after rebooting ~7 times). For me, a fixed package was available that made the manual modification unnecessary. My NX reboots without an issue now.

Edit: YMMV this worked for me.

doesn’t work :( did Nvidia made an update for it?

1 Like

You may try this. Before rebooting, be sure that kernel command line in /boot/extlinux/extlinux.conf is like this (should no longer have quiet):

DEFAULT primary

MENU TITLE L4T boot options

LABEL primary
      MENU LABEL primary kernel
      LINUX /boot/Image
      INITRD /boot/initrd
      APPEND ${cbootargs} root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0

TBH, I don’t know. After my system came back up, there was a new update per this post:

It’s possible it was pulled or an anomaly or something. Did you try editing the extlinux.conf as suggested? I did not, but you may want to try that if simply updating does not fix it for you.

@Honey_Patouceul ninja’d again! Thanks!

Hi archer.tavish.c,

Are you still able to modify the extlinux.conf in initrd?

Could you also share what you’ve done?

We just received some other post and they told us their device is working fine after apt-get update.

Thanks for your reply.

Yes, I still have access to extlinux.conf since although the device stuck again after reconfiguration, I can always boot it after 7 reboots. Here are what I have done:

I rebooted the device 7 times, it booted successfully. Then I go to extlinux.conf and noticed it already has the right arguments, so I rebooted and reconfigured the bootloader. After reconfiguration, the device stuck again.

After reading other posts, I realized that maybe having an SSD running Linux on my device is the reason why the arguments won’t work when I reconfigure the bootloader?

One more quick question, as we can already boot the system after 7 reboots, why do we still want to reconfigure the boot loader?

I think you should also run “sudo apt update” to make sure you are using the latest deb package.
If you keep using the old one, then it is probably not going to work especially you are using a case that mounts SSD as rootfs.