[BUG] driver v378.09 64 bits messes up colour channels [SOLVED in v378.13]

I just had a try at v378.09, and found out that 64 bits Second Life viewers had their colour channels messed up when not in deferred rendering (AKA “Advanced Lighting Model” or ALM, in SL jargon).

This does not happen when running the same viewers but in their 32 bits flavour, still on a 64 bits system, or when deferred rendering is enabled (which makes the viewers use an extended set of shaders).

I tried the major Linux Third Party Viewers (TPVs): Firestorm, Singularity and Cool VL Viewer, with the same results (note: Linden Lab, the maker of SL, does not yet provide 64 bits viewers, so their viewer is for now not affected).

I’m linking here two screen shots showing the ugly mess, and attaching the traditional nvidia-bug-report.log.gz file.

v378ChannelsOK.png
v378ChannelsKO.png

Reverting to v370.28, the last usable version for me (v375 being plagued with console restoration issues on X shutdown: see my former, still unaddressed reports)…
nvidia-bug-report.log.gz (221 KB)

Bump !

To NVIDIA devs:

Is this show-stopper bug being worked onto, please ?

Bump again…


Hi dinosaur_,
What desktop env you are running gnome, kde, unity or else? I’m not able to see v378ChannelsOK.png
v378ChannelsKO.png . Please attach it you your existing post.

>>their colour channels messed up when not in deferred rendering (AKA “Advanced Lighting Model” or ALM, in SL jargon).

How to enable/disable deferred rendering in apps you used ?
Could you please provide bug reproduction in details, this will help us to replicate this issue to debug?

This is irrelevant since I’m not using any compositor. Plain X11 (just tried it) or Mate desktop (my normal setup) yield the same results.

I attached the two pictures to my previous post, dated 02/08/2018 (although all what it would take would be to download them from the links I gave in my first post).
I hope the attachments total amount is not limited on this forum…

For Firestorm: in the menu bar, select “Viewer” then “Preferences” and from there the “Graphics” tab, “General” sub-tab, and finally (un)check “Advanced Lighting Model”.

For Singularity: in the menu bar, select “Edit” then “Preferences” and from there the “Graphics” tab, and finally (un)check “Advanced Lighting Model”.

For the Cool VL Viewer: in the menu bar, select “Edit” then “Preferences” and from there the “Graphics” tab, “Renderer settings” sub-tab, and finally (un)check “Advanced lighting model”. Once logged in, the Cool VL Viewer also entitles you to toggle ALM on/off with CTRL ALT D (“D” for Deferred rendering).

All you need to do is to download one of those viewers (or any 64 bits Linux SL viewer), launch it, log in with an avatar (create one from SL’s web site) and just see the ugly mess…

Hi dinosaur_, Is this issue reproduce with 375.26 ? Could you please test to confirm regression?

No, this issue is only present in v378. v375 and older versions are not affected by this particular issue.

Good news !

The new v378.13 driver seems to have fixed this bug…

What’s the make & model # of the graphics card and motherboard that your above observation was made on and which OS and kernel are you using?