Bug in AArch64 Platform Configuration? (VS2017)

Hi all, I’m updating some libraries to build for arm8-64 and I noticed an odd issue with the different platform configurations in VS2017 with NSight.

The Tegra-Android config allows for Target Architecture in the build settings to be selected:

With this configuration I can select the target architecture and the (AndroidArch) variable reflects the correct architecture. That handles 32-bit libs, however, I wanted to add a second platform config for 64-bit builds and so I used AArch64-Android-NVIDIA but under this platform configuration, I'm unable to select target architecture so I figured maybe it was just 64-bit only but when I look at the (AndroidArch) var, it’s still armv7-a:

I think the best soloution here is to create a new platform that copies the Tegra-Android settings and then just select armv8 as the target architecture.

Thoughts?

Hello,
I have the same problem with the platform x86 . The architecture that it use is armv7-a instead of x86. The binaries are also built for armv7-a and not for x86. It happens in the Nsight Tegra, Visual Studio Edition 3.6 in the previous version (3.5) it worked fine. Did you find any workaround ? I checked it in visual studio 2017 , Is it happen also in V.S. 2019?

I just ended up creating new configurations that target armv8 and will create two separate APK’s… one for 32-bit and another for 64-bit. This is actually better as you don’t need both binaries in one package when you can have two separate packages. Keeps the overall package size smaller.