[BUG]: In set_collision_approximation() method in GeometryPrim

I was setting the collision approximation for one of the Mesh objects. However, I got the following error on Terminal:

AttributeError: 'str' object has no attribute (Set)

When I navigated to the geometry_prim.py file (exts/omni.isaac.core/omni/isaac/core/prims/geometry_prim.py) and investigated the GeometryPrim class, I realized that the setter for the collision approximation (shown below), was calling Get() first, which would return a string. When I removed the Get() call, everything started working normally.

Furthermore, I think the doc strings for these two methods are also deprecated. The doc strings only mention “none”, “convexHull”, “convexDecomposition” as approximation methods, whereas when I tried out “boundingSphere”, everything worked just fine. (I am using Isaac Sim 2021.2.1)


Thanks for your feedback!

This bug has been fixed on release 2022.1.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.