BUG: PrimVars - works but kinda doesnt

I’m doing scene assembly of my various assets for the contest…


…and I’d gotten PrimVars to work, but, each time I open the file, its like its forgets somehow? - s’the best I can explain it - when I bounce the shader it remembers?

Hello @daryl.dunlap.ohio! I’ve messaged the dev team for more help with your question. Thanks for reaching out to us!

Hi @daryl.dunlap.ohio! Could you give me a few more details on how you are using PrimVars on your project? I’d like to understand what you are trying to do so that I can get the right person to help!

PrimVars are stored at the Vertex level on the Terrain prim, there is a Shader with a PrimVar reader node assigned to the Terrain, that has a default color of Magenta.

When the scene is loaded, you can see the default Magenta color, but whenever I touch the Shader assignment on the Terrain prim, even if that touch is unassigning a Shader, the PrimVar data is read and renders correctly.

Anything that triggers a reload of the Terrain prim, like, adding a Sublayer to the scene, causes the working PrimVar data to be lost, and the Magenta default color is presented again - until the Shader assignment is retouched.

Hope this helps, and let me know if you need anything else.

By any chance does the sublayer contain a delta with Terrain material assignment? Any chance you can collect and share this stage?

I’m turning in my contest submission tomorrow morning - but that’s a heavy file.

It’s very easy to reproduce and I’ll put something together when I get back from vacation in a few weeks - maybe just a plane with some PrimVar data.

1 Like

Hmm…out of curiosity I tried setting up a repro scene, and I cant get it to bug out now.

So, I’ve tried different things to get the mountain to behave the same, but, for some reason it does not. When I bring in grid_primvar into OV - it just works, but when I bring in mountains.usd, it does not work [meaning, the displayColor is not rendered by default for mountain, whereas, for grid_primvar it does]
grid_primvar.usd (22.9 MB)
mountains.usd (22.9 MB)

So, after some trial and error - I noticed this message in the console:

2022-06-23 21:19:26 [Warning] [omni.hydra] Mesh /terrain/height has corrupted data in primvar displayColor: buffer size 1 doesn’t match expected size 1000000 in vertex primvars

have you got the solution yet?