[Bug Report] Problem is still there: Purple spikes with 3080TI and HP Reverb G2

Hello, I am having purple spikes issues with a 3080Ti in virtual reality. It looks like the problem reported 1 year ago is still not entirely fixed, I have talked with other users around the community and we are still seing this issue in different games and scenarios.

The GPU has headroom and low frametimes, but you can see purple spikes in some scenarios. I have tried absolutely everything: older drivers, DDU, disabled game mode, disabled hardware gpu schedule, closed all unnecesary apps (including monitoring ones), disabled Geforce in-game overlay, uninstalled geforce experience, OpenXR instead of SteamVR, lock GPU frequency, etc.

It just not get fixed, and it is a GPU issue 100% sure. Why? because I had AMD 6900XT installed on exactly the same hardware and this issue didn’t happen at the same game and scenario.

These are my specs:

  • Headset: HP Reverb G2
  • GPU: Gigabyte RTX 3080Ti Gaming OC
  • Motherboard: MSI X570 Tomahawk Wifi
  • RAM: 32 GB (4x8) 3600 mhz (XMP Profile 1)
  • CPU: AMD Ryzen 7 5800x3D
  • BIOS: Agesa
  • OS: Windows 10 22H2 (updated to latest version)

So, I could see this issue in rFactor 2, but I also could see it in VRChat for example. It looks like the purple spikes appear when the GPU is pushed to the limits, like there is an issue with power delivery, lost bus, or something like that.

Here I recorded a video showing the problem: VID20221016185734 - YouTube

Since I got the 3080Ti in exchange of the 6900XT, I could notice this issue in different games and scenarios, it is like: it works butter smooth, but 5 mins after you get purple spikes which don’t get away even restarting everything.

My GPU and CPU temperatures are fine (as you can see in the video), there is nothing wrong with my config or hardware, other users are having issues too as you can see in this thread for example:

forum . studio-397 . com/index.php?threads/huge-frame-drops-in-vr-purple-lag-spikes-unplayable-on-each-setting-with-the-reverb-g2-3080.70075/

Please, look at this bug, it is a real problem for VR, as you can get a bad experience in some scenarios, as stuttering is something you notice a lot while in the headset.

I can not find any solution, so that’s why I am posting this here, I can only think of going back to AMD by getting 7900XT instead of 4090, but that’s something I don’t want to do as the Nvidia is a better card for VR (when it works).