[Bug] Serving 2 displays via Thunderbolt not working anymore with 530.41.03 under X11 & framebuffer

With nvidia driver v530.41.03, X11 and the framebuffer for getty are only able to serve one screen, the 2nd one gets detected and controlled by X11, but will stay black.

With sway and those settings, though, both displays will show output, albeit the 2nd display will sometimes go black for a second before coming up again.

export GBM_BACKEND=nvidia-drm
export WLR_RENDERER=vulkan
exec systemd-cat sway --unsupported-gpu

Tried with Archlinux’ 6.3.3 & 6.2.13 kernels.
Both displays get served by EFI and work fine on Windows.

Driver 525.85.05 works fine, but dkms will fail with any kernel >= 6.3.
Can confirm it works fine with 6.2.13, LTS 6.1 & LTS 5.15.

nvidia-bug-report.log.gz (816.0 KB)

Log of the 2nd display staying black despite being recognized:
Xorg.0.log (27.1 KB)

(I had to do this because of the dumb link limiting rule. My nvidia account is not new, get your forum software straight.)

Probably related to 525.89 brings back Thunderbolt 3 connected displays flicker and suspend issues

(Same forum software problem, I have to make 1 post per link).

Under driver v525.89.02 only one framebuffer works and Xorg doesn’t show a picture on any thunderbolt-connected screen.
Sway with the settings from above continues to work fine.

xorg-log_525.89.02.log (32.7 KB)

Hi All,
Need below data to isolate and debug issue further.

  1. output of the “xrandr -q”
  2. On the blanked display try to change the resolution using xrandr command similar to
    “xrandr --output DP-2 --mode 2560x1440 --rate 120.00”

I also included tmux.out, which is a capture of all xrandr commands I tried and the Xorg.log of this session: I didn’t get any response on the 2nd screen. My monitor is actually DP-0.2 not DP-2 since they’re daisychained over thunderbolt.

nvidia-2023-07-03.tar (60 KB)

Thanks @oroesler for the logs.
Team will review the logs and shall update accordingly.

Sorry about the inconvenience and thanks for your patience. Even though your NVIDIA Account isn’t new your forum account was considered new. These limitations are a side effect of our on going battle against bots and spam posts.
Thanks again.

Unfortunately, I am still not able to repro issue locally, could you please help to share EDID information for displays which has been used in your setup.

could you please help to share EDID information for displays which has been used in your setup.

Sorry for not responding earlier. Here are my EDIDs:

EDID_DP-0.1.txt (768 Bytes)

EDID_DP-0.2.txt (768 Bytes)

I’m happy to tell you that the bug is gone with the new beta version 545.23.06. Running 2 displays under Xorg does work now.

1 Like

Thanks for sharing the feedback.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.