Build error with isaac_ros_visual_slam

I’m trying to run Isaac ROS Visual SLAM following the instructions, when do ./scripts/, but I’ve got that error:

 => ERROR [1/1] FROM  804.1s
 > [1/1] FROM
   7 |     # license agreement from NVIDIA CORPORATION is strictly prohibited.
   8 |     
   9 | >>> FROM
  10 |     
ERROR: failed to solve: failed to fetch anonymous token: unexpected status: 401 Unauthorized
Failed to build base image: isaac_ros_dev-x86_64, aborting.

We used ros2 foxy

1 Like

I have the same problem trying to run Isaac ROS DNN Inference tutorial on YOLOv5.

We’re working on restoring anonymous downloading of images from NGC which is why the above 401 Unauthorized is happening. I’ll update as soon as it is fixed.

I had the same problem, is it solved now?

same problem

This should have been fixed earlier. Please let us know if you have any trouble still.

I’m having the same error while rebuilding the isaac_ros_dev-x86_64 image before running librealsense (my goal is to test the vSLAM as well)

[UPDATE] I momentarily bypassed the problem by pulling first (docker pull and then running ./scripts/ ${ISAAC_ROS_WS}

1 Like

i solved this issue by generating a new ngc key

1 Like

The Isaac ROS Dev images on NGC should not require authentication or an NGC key to pull down. If you need to generate an NGC key or authenticate, please let us know.

I got this error pulling the humble ros image on orin agx and xavier nx. After i generate a ngc key and login on both systems the error was gone.

1 Like

This worked for me. Thanks for sharing. I’ve been dealing with this issue for a couple days now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.