Build own nano Image on linux host failed

HI everyone:
I am trying to build my own Image with nano kernel source as the quick start guide and Start_L4T_Docs.html
but when I execute the following steps:

1.tar -xjf public_sources.tbz2
2. cd sources
tar -xjf kernel_src.tbz2
3.sudo apt install build-essential bc

4.export CROSS_COMPILE=/topdir/install/bin/aarch64-unknown-linux-gnu-
5.export TEGRA_KERNEL_OUT=/home/<destination_dir>
6.cd <kernel_source>
mkdir -p $TEGRA_KERNEL_OUT
make ARCH=arm64 O=$TEGRA_KERNEL_OUT tegra_defconfig
7.make ARCH=arm64 O=$TEGRA_KERNEL_OUT -j4 Or make ARCH=arm64 O=$TEGRA_KERNEL_OUT Image -j4 Or make ARCH=arm64 O=$TEGRA_KERNEL_OUT dtbs

when i execute the final steps7,the erro log as follows :

xxx@service-host:~/Jetson-nano/public_sources/kernel/kernel-4.9$ make ARCH=arm64 O=$TEGRA_KERNEL_OUT -j4
make[1]: Entering directory `/home/zxd/Jetson-nano/kernel_out'
arch/arm64/Makefile:49: LSE atomics not supported by binutils
  CHK     include/config/kernel.release
  GEN     ./Makefile
  CHK     include/generated/uapi/linux/version.h
  Using /home/zxd/Jetson-nano/public_sources/kernel/kernel-4.9 as source for kernel
  CHK     include/generated/utsrelease.h
  CC      scripts/mod/devicetable-offsets.s
/home/zxd/Jetson-nano/public_sources/kernel/kernel-4.9/scripts/mod/devicetable-offsets.c: In function ‘main’:
/home/zxd/Jetson-nano/public_sources/kernel/kernel-4.9/scripts/mod/devicetable-offsets.c:210:1: sorry, unimplemented: function profiling
 }
 ^
make[3]: *** [scripts/mod/devicetable-offsets.s] Error 1
make[2]: *** [scripts/mod] Error 2
make[1]: *** [scripts] Error 2
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/home/zxd/Jetson-nano/kernel_out'
make: *** [sub-make] Error 2
zxd@service-host:~/Jetson-nano/public_sources/kernel/kernel-4.9$

Does anybody have a similar situation?

Did you use the 7.3 toolchain?
http://releases.linaro.org/components/toolchain/binaries/7.3-2018.05/aarch64-linux-gnu

Please use 7.3 to build and add below before make the configure.
export LOCALVERSION=-tegra

Hi ShaneCCC :
Thanks for your reply!
I used your recommended 7.3 toolchain to compile Image successfully! but I download the official pre-compiled package gcc-4.8.5-aarch64.tgz to built nano kernel failed actually! I give you this feedback.
The another question as follows:
I follow the quick start guide to follow the steps below:
sudo tar xpf {L4T_RELEASE_PACKAGE} cd Linux_for_Tegra/rootfs/ sudo tar xpf ../../{SAMPLE_FS_PACKAGE}
cd …
sudo ./apply_binaries.sh
When I run the command sudo./ apply_binaries.sh with the following error log :

xxx@service-host:~/Jetson-nano/Linux_for_Tegra$ sudo ./apply_binaries.sh
Using rootfs directory of: /home/xxx/Jetson-nano/Linux_for_Tegra/rootfs
Extracting the NVIDIA user space components to /home/xxx/Jetson-nano/Linux_for_Tegra/rootfs
tar (child): lbzip2: Cannot exec: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
xxx@service-host:~/Jetson-nano/Linux_for_Tegra$

I did experiments on Ubuntu14.04 host and Ubuntu16.04 host and got the same error log.
My development environment did not have similar problems when developing on tx1 and tx2. Please indicate where the problems might be and give corresponding guidance.
Best regards!

Try to install lbzip2 by below command
sudo apt-get install bzip2

Hi ShaneCCC
Thanks for your prompt reply!
I make it successfully. Another post I made at forum didn’t get any reply now. I hope you can give me some advice.best regards!!!
Here are the questions:
In the jetson_nano_module_pinmux_config_template.xlsm file, the function USB_SS2 is described in SFIO1 of pcie3. But Only one usb3.0 and PCIe Configurations is written in the OEM Jetson nano Only USB 3.0 & PCIe Lane Mapping Configurations table.
I would like to add a usb3.0 interface with a pcie lane3 on our custom board.What if I designed the existing nvidia software support like this? If not, any advice or guidance?

@zhangxd260

NV only support what we claim in the module datasheet. Even if technically T210 UPHY config could support more by default we won’t be enabling them.