Building kernel from source, stuck trying to start HDMI

While trying to build a new kernel with the Raspberry Pi HQ Camera, according to instructions at.

I get stuck in while booting trying to start HDMI, monitor blinks black and then return to bootlog, repeatedly.

Tried building a non-patched kernel, but still get the same problem.

Flashing .dtb file works fine, system starts up.

As soon as a replace the /boot/Image file I get the problem.

Boot log says

[FAILED] Failed to start Load Kernel Modules.

Is it correct that you replaced “/boot/Image”? If so, did you set up “CONFIG_LOCALVERSION”? If not, then the kernel won’t be able to find the modules.

The command “uname -r” is a combination of the base kernel version, plus the CONFIG_LOCALVERSION. The default CONFIG_LOCALVERSION for Jetsons is “-tegra”. Thus, if you do not have this in the Image’s config, then “uname -r” will not match:

The modules are searched for at:
/lib/modules/$(uname -r)/kernel/

I’d instead suggest you rebuild the modules and use “make modules_install” to update them with your compiled kernel. Don’t forget to strip them.