Building PhysX 3.3.2 for Android

I’m trying to build PhysX 3.3.2 for Android. But I’m having a hard time building it on our machines.

Is there an apropriate NVidia devpack version I can use to ensure everything is correct? We use the latest devpack (3.0r3) and I would like to avoid having multiple ones installed.

I’m assuming you have a source license, but what problems are issues are you encountering ? Saying I’m having a hard times give no indication as to what the problem could be.

3.0r3 should be fine. I’ll try it and see what happens.

@busta78: The questin was more about what NDK/devpack version you want me to use. And is it suppose to work with 3.0r3. :)

I end up with this build error.

PhysXCommon: compiling release ./../../foundation/src/PsAllocator.cpp...
In file included from ./../../foundation/src/PsAllocator.cpp:31:0:
./../../foundation/include/PsAllocator.h:51:15: fatal error: new: No such file o
r directory
 #include <new>
compilation terminated.

It feels strange… I have reinstalled the devpack. (And tried several versions.)
If you think that 3.0r3 will work then I can try to do another reinstall.

(I have a source license.)


–>what NDK/devpack version you want me to use

The readme indicates the following:

•To reduce the size of the package we removed some external libraries, these have to be copied first to the “externals” folder. Empty folders are already in place to define the layout and the required version.
◦Android NDK: Version r9d
◦Android SDK: Android-10 Headers needed, (adb for deploying to device)
◦Apache Ant: Version 1.8.2.

I’m not sure if the error you encountered is due to 3.0r3 or not, I am trying to find that out.



If we could build it with 3.0r3 that would be great. I have tried to copy the NDK r9d and the one included in the 3.0r3 devpack but I get the same result.